ramips: consolidate recipes with uimage_padhdr
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 10 Jul 2020 12:16:23 +0000 (14:16 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 11 Jul 2020 16:38:42 +0000 (18:38 +0200)
There are already two very similar recipes using uimage_padhdr
in ramips target, and a third one is about to be added.

Make the recipe more generic, so redefinitions are not necessary
anymore.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Tested-by: Bjørn Mork <bjorn@mork.no> [Zyxel WAP6805]
target/linux/ramips/image/Makefile
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt7621.mk

index 93ce59e2629dff4e5f9b04f4cffd6c7e42cd9cfd..3ee9828a646683cfda303740e83cc3da9097fa0d 100644 (file)
@@ -51,11 +51,6 @@ define Build/elx-header
        rm -rf $(KDIR)/tmp/$(DEVICE_NAME).header
 endef
 
-define Build/fonfxcimage
-       uimage_padhdr -i $@ -o $@.new
-       mv $@.new $@
-endef
-
 define Build/jcg-header
        $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
                $(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \
@@ -151,6 +146,11 @@ define Build/trx
                -a 4 -f $(IMAGE_ROOTFS)
 endef
 
+define Build/uimage-padhdr
+       uimage_padhdr $(if $(1),-l $(1)) -i $@ -o $@.new
+       mv $@.new $@
+endef
+
 define Build/umedia-header
        fix-u-media-header -T 0x46 -B $(1) -i $@ -o $@.new && mv $@.new $@
 endef
index df3f0500485117c7989ea42b4a53513099b8ed98..34e2e42c330a957cde32fad59e084a40b472db47 100644 (file)
@@ -400,8 +400,8 @@ define Device/fon_fon2601
   DEVICE_VENDOR := Fon
   DEVICE_MODEL := FON2601
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
-  KERNEL_INITRAMFS := $$(KERNEL) | fonfxcimage
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | fonfxcimage | \
+  KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr | \
        pad-rootfs | append-metadata | check-size
 endef
 TARGET_DEVICES += fon_fon2601
index 0215683671b257c7d8357d6447e32d77c8537f3e..25de2fa5973163417fb843370c6979bb5239f81d 100644 (file)
@@ -81,11 +81,6 @@ define Build/iodata-mstc-header
        )
 endef
 
-define Build/mitrastarimage
-       uimage_padhdr -l 160 -i $@ -o $@.new
-       mv $@.new $@
-endef
-
 define Build/ubnt-erx-factory-image
        if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
                echo '21001:7' > $(1).compat; \
@@ -1146,7 +1141,7 @@ define Device/zyxel_wap6805
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := WAP6805
   DEVICE_PACKAGES := kmod-mt7603 wpad-basic kmod-mt7621-qtn-rgmii
-  KERNEL := $(KERNEL_DTB) | uImage lzma | mitrastarimage
+  KERNEL := $(KERNEL_DTB) | uImage lzma | uimage-padhdr 160
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
 endef
 TARGET_DEVICES += zyxel_wap6805