target: fix copying of licenses for SDK/toolchain
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 14 Feb 2021 20:51:14 +0000 (21:51 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 14 Feb 2021 20:56:29 +0000 (21:56 +0100)
The SDK and target/toolchain copy the license file into their
directories. During the rename/move from LICENSE to a LICENSES
folder, this has not been updated.

Update it now, and include the new COPYING file.

While at it, improve formatting/indent.

Fixes: 882e3014610b ("LICENSES: include all used licenses in
LICENSES directory")

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/sdk/Makefile
target/toolchain/Makefile

index d7e10a9bd85bf5e38194ae71751fb3296f060f3d..0606621192c7508fc7a470eff0173dc62ff70ded 100644 (file)
@@ -130,7 +130,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
                $(SDK_BUILD_DIR)/target/linux/*/patches*
        ./convert-config.pl $(TOPDIR)/.config > $(SDK_BUILD_DIR)/Config-build.in
        $(CP) -L \
                $(SDK_BUILD_DIR)/target/linux/*/patches*
        ./convert-config.pl $(TOPDIR)/.config > $(SDK_BUILD_DIR)/Config-build.in
        $(CP) -L \
-               $(TOPDIR)/LICENSE \
+               $(TOPDIR)/LICENSES \
+               $(TOPDIR)/COPYING \
                $(TOPDIR)/rules.mk \
                ./files/Config.in \
                ./files/Makefile \
                $(TOPDIR)/rules.mk \
                ./files/Config.in \
                ./files/Makefile \
index 5002ff7835b22618fa802fbb8a0312f07de92e0f..c3ba70db04ed7e4041f06d22b28c3109c338c8dd 100644 (file)
@@ -33,7 +33,10 @@ $(BIN_DIR)/$(TOOLCHAIN_NAME).tar.bz2: clean
               toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)$(DIR_SUFFIX) | \
               $(TAR) -xf - -C $(TOOLCHAIN_BUILD_DIR)
 
               toolchain-$(ARCH)$(ARCH_SUFFIX)_gcc-$(GCCV)$(DIR_SUFFIX) | \
               $(TAR) -xf - -C $(TOOLCHAIN_BUILD_DIR)
 
-       $(CP)  $(TOPDIR)/LICENSE ./files/README.TOOLCHAIN \
+       $(CP) \
+               $(TOPDIR)/LICENSES \
+               $(TOPDIR)/COPYING \
+               ./files/README.TOOLCHAIN \
                $(TOOLCHAIN_BUILD_DIR)/
 
        $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh
                $(TOOLCHAIN_BUILD_DIR)/
 
        $(CP) ./files/wrapper.sh $(TOOLCHAIN_PREFIX)/bin/$(REAL_GNU_TARGET_NAME)-wrapper.sh