mvebu: clearfog: document interface configuration
authorJosua Mayer <josua.mayer97@gmail.com>
Mon, 24 Apr 2017 14:52:31 +0000 (16:52 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 30 May 2017 12:00:30 +0000 (14:00 +0200)
Take explicit note of what physical ports eth{0,1,2} refer to.
Also repair port assignment:
At some point between 4.9.20 and 4.9.29 the numbering changed.
Keep previous port assignment that was:
LAN = SFP+Switch
WAN = standalone ethernet

Also use the same assignment for Clearfog-Base to avoid confusion.

Signed-off-by: Josua Mayer <josua.mayer97@gmail.com>
target/linux/mvebu/base-files/etc/board.d/02_network

index aea6224..57ffbb4 100755 (executable)
@@ -27,14 +27,17 @@ armada-385-db-ap)
 armada-xp-gp)
        ucidef_set_interface_lan "eth0 eth1 eth2 eth3"
        ;;
-armada-388-clearfog-pro)
-       ucidef_set_interfaces_lan_wan "eth0 eth1" "eth2"
+armada-388-clearfog-*)
+       # eth0 is standalone ethernet
+       # eth1 is switch (-pro) or standalone ethernet (-base)
+       # eth2 is SFP
+       ucidef_set_interfaces_lan_wan "eth1 eth2" "eth0"
+
+       # if switch exists (clearfog-pro)
+       # switch port 5 is connected to eth1
        swconfig list 2>&1 | grep -q switch0 && \
                ucidef_add_switch "switch0" \
-                       "0:lan:5" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5u@eth0" "6:lan:6"
-       ;;
-armada-388-clearfog-base)
-       ucidef_set_interfaces_lan_wan "eth0" "eth1"
+                       "0:lan:5" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1" "5u@eth1" "6:lan:6"
        ;;
 *)
        ucidef_set_interface_lan "eth0"