ar71xx: refresh patches
authorLuka Perkov <luka@openwrt.org>
Mon, 20 Apr 2015 20:47:53 +0000 (20:47 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 20 Apr 2015 20:47:53 +0000 (20:47 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 45528

target/linux/ar71xx/patches-3.18/610-MIPS-ath79-openwrt-machines.patch
target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
target/linux/ar71xx/patches-3.18/736-MIPS-ath79-add-MC-MAC1200R-support.patch
target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
target/linux/ar71xx/patches-3.18/800-MIPS-ath79-add-RB922GS-support.patch
target/linux/ar71xx/patches-3.18/902-unaligned_access_hacks.patch

index 5e07d8051130a13924a5e7d1d654544456d46c73..f8a561c0b0a456f197a2b1207e316b833acade7e 100644 (file)
  endif
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
  endif
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -38,9 +48,120 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
+@@ -38,9 +38,120 @@ obj-$(CONFIG_ATH79_ROUTERBOOT)             += route
  #
  # Machines
  #
  #
  # Machines
  #
index 1f6a4d23ba3b87c3b853aba54cf95a75a85ea497..09e911970a56caef1f7734bb87ffec83dc97fd46 100644 (file)
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1174,6 +1174,10 @@ config SOC_AR934X
+@@ -1184,6 +1184,10 @@ config SOC_AR934X
        select PCI_AR724X if PCI
        def_bool n
  
        select PCI_AR724X if PCI
        def_bool n
  
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
-@@ -1216,7 +1220,7 @@ config ATH79_DEV_USB
+@@ -1226,7 +1230,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
        def_bool n
  
  config ATH79_DEV_WMAC
index 2e1ae29e5857b7482abaa0e09a88da088d70f71e..7a3605ea1ac939bfd9e4106d4f8a711d181c4de6 100644 (file)
                        pdata->phy_if_mode = PHY_INTERFACE_MODE_GMII;
                        break;
  
                        pdata->phy_if_mode = PHY_INTERFACE_MODE_GMII;
                        break;
  
-@@ -992,6 +1002,8 @@ void __init ath79_register_eth(unsigned
+@@ -1018,6 +1028,8 @@ void __init ath79_register_eth(unsigned
                break;
  
        case ATH79_SOC_QCA9533:
                break;
  
        case ATH79_SOC_QCA9533:
                if (id == 0) {
                        pdata->reset_bit = AR933X_RESET_GE0_MAC |
                                           AR933X_RESET_GE0_MDIO;
                if (id == 0) {
                        pdata->reset_bit = AR933X_RESET_GE0_MAC |
                                           AR933X_RESET_GE0_MDIO;
-@@ -1097,6 +1109,8 @@ void __init ath79_register_eth(unsigned
+@@ -1123,6 +1135,8 @@ void __init ath79_register_eth(unsigned
                case ATH79_SOC_AR9330:
                case ATH79_SOC_AR9331:
                case ATH79_SOC_QCA9533:
                case ATH79_SOC_AR9330:
                case ATH79_SOC_AR9331:
                case ATH79_SOC_QCA9533:
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
  }
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1183,6 +1183,12 @@ config SOC_QCA955X
+@@ -1193,6 +1193,12 @@ config SOC_QCA955X
        select PCI_AR724X if PCI
        def_bool n
  
        select PCI_AR724X if PCI
        def_bool n
  
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
-@@ -1220,7 +1226,7 @@ config ATH79_DEV_USB
+@@ -1230,7 +1236,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
        def_bool n
  
  config ATH79_DEV_WMAC
index d38e82300f3e6418c4a13c10fa5542680003b4fc..1c84b20b1b60a994bed805105731844ba0c3c53f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -524,6 +524,16 @@ config ATH79_MACH_R6100
+@@ -534,6 +534,16 @@ config ATH79_MACH_R6100
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
index 0d493f6f95157daaa369bb978fb8fec6e83ea3dd..b7d57c31e72a13d06c2e2bca928772a670ad076e 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_PB92,                /* Atheros PB92 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
        ATH79_MACH_PB92,                /* Atheros PB92 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -677,6 +677,7 @@ config ATH79_MACH_OM2P
+@@ -687,6 +687,7 @@ config ATH79_MACH_OM2P
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
index d206f3b89cbe1e187d7451a20f80aa926dacbb7e..01dcb7296b434c36145a0ea6f435ed4093429326 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -559,6 +559,16 @@ config ATH79_MACH_RB91X
+@@ -569,6 +569,16 @@ config ATH79_MACH_RB91X
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
index 9afac1be63e14a3b2756385a385d82034bcf3c9c..bab573673505f7661f4813ad6c8dadda2a27c72e 100644 (file)
  #include <linux/uaccess.h>
  #include <linux/ipv6.h>
  #include <linux/icmpv6.h>
  #include <linux/uaccess.h>
  #include <linux/ipv6.h>
  #include <linux/icmpv6.h>
-@@ -833,10 +834,10 @@ static void tcp_v6_send_response(struct 
+@@ -833,10 +834,10 @@ static void tcp_v6_send_response(struct
        topt = (__be32 *)(t1 + 1);
  
        if (tsecr) {
        topt = (__be32 *)(t1 + 1);
  
        if (tsecr) {
  
 --- a/net/sched/cls_u32.c
 +++ b/net/sched/cls_u32.c
  
 --- a/net/sched/cls_u32.c
 +++ b/net/sched/cls_u32.c
-@@ -148,7 +148,7 @@ next_knode:
+@@ -151,7 +151,7 @@ next_knode:
                        data = skb_header_pointer(skb, toff, 4, &hdata);
                        if (!data)
                                goto out;
                        data = skb_header_pointer(skb, toff, 4, &hdata);
                        if (!data)
                                goto out;
                                n = rcu_dereference_bh(n->next);
                                goto next_knode;
                        }
                                n = rcu_dereference_bh(n->next);
                                goto next_knode;
                        }
-@@ -201,8 +201,8 @@ check_terminal:
+@@ -204,8 +204,8 @@ check_terminal:
                                                  &hdata);
                        if (!data)
                                goto out;
                                                  &hdata);
                        if (!data)
                                goto out;
  #include <linux/netdevice.h>
 --- a/include/net/inet_ecn.h
 +++ b/include/net/inet_ecn.h
  #include <linux/netdevice.h>
 --- a/include/net/inet_ecn.h
 +++ b/include/net/inet_ecn.h
-@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct 
+@@ -115,13 +115,13 @@ static inline int IP6_ECN_set_ce(struct
  {
        if (INET_ECN_is_not_ect(ipv6_get_dsfield(iph)))
                return 0;
  {
        if (INET_ECN_is_not_ect(ipv6_get_dsfield(iph)))
                return 0;
                                       | TCPOLEN_TIMESTAMP))
 --- a/net/xfrm/xfrm_input.c
 +++ b/net/xfrm/xfrm_input.c
                                       | TCPOLEN_TIMESTAMP))
 --- a/net/xfrm/xfrm_input.c
 +++ b/net/xfrm/xfrm_input.c
-@@ -152,8 +152,8 @@ int xfrm_parse_spi(struct sk_buff *skb, 
+@@ -152,8 +152,8 @@ int xfrm_parse_spi(struct sk_buff *skb,
        if (!pskb_may_pull(skb, hlen))
                return -EINVAL;
  
        if (!pskb_may_pull(skb, hlen))
                return -EINVAL;