tools/dosfstools: Update to 4.1
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Tue, 14 Mar 2017 07:23:10 +0000 (08:23 +0100)
committerJohn Crispin <john@phrozen.org>
Mon, 20 Mar 2017 07:24:05 +0000 (08:24 +0100)
Update to 4.1
Remove 0001-mkfs-Default-to-64-32-heads-sectors-for-targets-smal.patch
as it's included in upstream repo.
Refresh patch

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
tools/dosfstools/Makefile
tools/dosfstools/patches/0001-mkfs-Default-to-64-32-heads-sectors-for-targets-smal.patch [deleted file]
tools/dosfstools/patches/0002-Switch-to-AC_CHECK_LIB-for-iconv-library-linking.patch

index d0620f1ffa0276a84d7e3c5e05ca5f9642911351..861dcbf1c74932f318fc2edfec18741eab3c7d6e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
-PKG_VERSION:=4.0
+PKG_VERSION:=4.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
                http://fossies.org/linux/misc
-PKG_HASH:=9037738953559d1efe04fc5408b6846216cc0138f7f9d32de80b6ec3c35e7daf
+PKG_HASH:=e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b7412471cc173
 
 HOST_FIXUP:=autoreconf
 
diff --git a/tools/dosfstools/patches/0001-mkfs-Default-to-64-32-heads-sectors-for-targets-smal.patch b/tools/dosfstools/patches/0001-mkfs-Default-to-64-32-heads-sectors-for-targets-smal.patch
deleted file mode 100644 (file)
index 76672e0..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From 1e76e5778a1885452939a79d9145b80634a5b023 Mon Sep 17 00:00:00 2001
-From: Andreas Bombe <aeb@debian.org>
-Date: Wed, 11 May 2016 03:44:58 +0200
-Subject: [PATCH] mkfs: Default to 64/32 heads/sectors for targets smaller than
- 512 MB
-
-This may put defaults in certain use cases a little bit more in line
-with the old defaults in versions up to 3.0.28. It has mostly aesthetic
-value in most cases.
-
-Signed-off-by: Andreas Bombe <aeb@debian.org>
----
- src/mkfs.fat.c | 10 ++++++++++
- 1 file changed, 10 insertions(+)
-
---- a/src/mkfs.fat.c
-+++ b/src/mkfs.fat.c
-@@ -519,6 +519,16 @@ static void establish_params(struct devi
-     unsigned int cluster_size = 4;  /* starting point for FAT12 and FAT16 */
-     int def_root_dir_entries = 512;
-+    if (info->size < 512 * 1024 * 1024) {
-+      /*
-+       * These values are more or less meaningless, but we can at least
-+       * use less extreme values for smaller filesystems where the large
-+       * dummy values signifying LBA only access are not needed.
-+       */
-+      sec_per_track = 32;
-+      heads = 64;
-+    }
-+
-     if (info->type != TYPE_FIXED) {
-       /* enter default parameters for floppy disks if the size matches */
-       switch (info->size / 1024) {
index 72a932dfd53d3a5eb1fcb77c3915d712ab717c56..ea9332082169e9140547fd2aa7544b1d1b899a44 100644 (file)
@@ -23,5 +23,5 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 -AC_SEARCH_LIBS(iconv_open, iconv)
 +AC_CHECK_LIB(iconv, iconv_open)
  
- AC_CONFIG_FILES([Makefile src/Makefile src/version.h
-                manpages/Makefile manpages/mkfs.fat.8
+ # xxd (distributed with vim) is used in the testsuite
+ AC_CHECK_PROG([XXD_FOUND], [xxd], [yes])