toolchain: get rid of uclibc version kconfig symbol overloading
authorFelix Fietkau <nbd@openwrt.org>
Thu, 18 Apr 2013 12:04:48 +0000 (12:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 18 Apr 2013 12:04:48 +0000 (12:04 +0000)
SVN-Revision: 36356

toolchain/uClibc/Config.in
toolchain/uClibc/Config.version

index 74d15ae..08ea00a 100644 (file)
@@ -3,16 +3,16 @@
 choice
        prompt "uClibc Version"
        depends on TOOLCHAINOPTS && USE_UCLIBC
-       default UCLIBC_VERSION_0_9_33
+       default UCLIBC_USE_VERSION_0_9_33
        help
          Select the version of uClibc you wish to use.
 
-       config UCLIBC_VERSION_0_9_33
+       config UCLIBC_USE_VERSION_0_9_33
+               select UCLIBC_VERSION_0_9_33
                bool "uClibc 0.9.33.2"
 
 endchoice
 
-
 # Debug version.
 
 config UCLIBC_ENABLE_DEBUG
index 0d0b4a7..dd302f2 100644 (file)
@@ -4,10 +4,6 @@ config UCLIBC_VERSION
        default "0.9.33.2"       if UCLIBC_VERSION_0_9_33
        default "0.9.33.2"
 
-if !TOOLCHAINOPTS
-
-       config UCLIBC_VERSION_0_9_33
-               default y if USE_UCLIBC
-               bool
-
-endif
+config UCLIBC_VERSION_0_9_33
+       default y if !TOOLCHAINOPTS && USE_UCLIBC
+       bool