uhttpd: fix parameter parsing issue on avr32 and most likely ixp4xx
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 28 Mar 2010 02:35:45 +0000 (02:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 28 Mar 2010 02:35:45 +0000 (02:35 +0000)
SVN-Revision: 20532

package/uhttpd/Makefile
package/uhttpd/src/uhttpd.c

index 2b7714d30fcc33665b4a51e1829bff248894daec..4bee17d234086f0305bc03f39915e0666233b003 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
@@ -56,6 +56,7 @@ endef
 
 # hack to use CyASSL headers
 TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+TARGET_LDFLAGS += -lm
 MAKE_VARS += FPIC="$(FPIC)"
 
 define Build/Prepare
index be13b536d76c3d62cd7a5bff6b0845b51b59bff2..c6a8b6c272caadbe01dfc282846fa18a38de7a89 100644 (file)
@@ -422,7 +422,7 @@ int main (int argc, char **argv)
        int nofork = 0;
 
        /* args */
-       char opt;
+       int opt;
        char bind[128];
        char *port = NULL;