build: do not overwrite already existing host commands
authorFelix Fietkau <nbd@openwrt.org>
Wed, 16 Sep 2015 12:38:16 +0000 (12:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 16 Sep 2015 12:38:16 +0000 (12:38 +0000)
This prevents a later prereq check from overwriting the installed tar
binary.

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 46982

include/prereq.mk

index 33ac27823297b0ab86d98013aaeb8fc3f53321a7..6cb590e360aab351b567e8b76dfa35a98815d4af 100644 (file)
@@ -86,6 +86,7 @@ endef
 # 3+: candidates
 define SetupHostCommand
   define Require/$(1)
+       [ -f "$(STAGING_DIR_HOST)/bin/$(strip $(1))" ] && exit 0; \
        for cmd in $(call QuoteHostCommand,$(3)) $(call QuoteHostCommand,$(4)) \
                   $(call QuoteHostCommand,$(5)) $(call QuoteHostCommand,$(6)) \
                   $(call QuoteHostCommand,$(7)) $(call QuoteHostCommand,$(8)) \