dropbear: Fix incorrect CONFIG_TARGET_INIT_PATH.
authorDario Ernst <Dario.Ernst@riverbed.com>
Tue, 24 May 2016 14:06:07 +0000 (16:06 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 24 May 2016 14:31:17 +0000 (16:31 +0200)
Fix a „semantic typo“ introduced in b78aae793e20e06defa1e75ab4d30dbb6807c139,
where TARGET_INIT_PATH was used instead of CONFIG_TARGET_INIT_PATH.

Signed-off-by: Dario Ernst <Dario.Ernst@riverbed.com>
package/network/services/dropbear/Makefile

index 6e5112c67f7d905c4829436bc0338d87692b3d57..9d62e926b41787a226f73a00fd28b76aaa9dfff4 100644 (file)
@@ -78,13 +78,13 @@ CONFIGURE_ARGS += \
        --disable-zlib \
        --enable-bundled-libtom
 
        --disable-zlib \
        --enable-bundled-libtom
 
-TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
+TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(CONFIG_TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 define Build/Configure
        $(Build/Configure/Default)
 
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 define Build/Configure
        $(Build/Configure/Default)
 
-       $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(TARGET_INIT_PATH)",g' \
+       $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(CONFIG_TARGET_INIT_PATH)",g' \
                $(PKG_BUILD_DIR)/options.h
 
        awk 'BEGIN { rc = 1 } \
                $(PKG_BUILD_DIR)/options.h
 
        awk 'BEGIN { rc = 1 } \