base-files: sysupgrade: restrict find command to plain files to avoid duplicates...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Nov 2009 23:02:35 +0000 (23:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 20 Nov 2009 23:02:35 +0000 (23:02 +0000)
SVN-Revision: 18455

package/base-files/Makefile
package/base-files/files/sbin/sysupgrade

index 8138f1cd4d9f791cb8f5e2cef07c1b1cf219cdeb..5957f1406b5203840922a7efc86d1b3686ca365c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=33
+PKG_RELEASE:=34
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index a582d432f8e981a2fd2cb25d57a768f3743db5dd..0cf51cfb78692686766b14ba145ff3a92c5fae4f 100755 (executable)
@@ -51,7 +51,8 @@ EOF
 
 add_uci_conffiles() {
        local file="$1"
-       find /etc/config /etc/passwd /etc/group /etc/dropbear /etc/firewall.user /etc/rc.local > "$file"
+       find /etc/config /etc/passwd /etc/group /etc/dropbear \
+               /etc/firewall.user /etc/rc.local -type f > "$file"
        return 0
 }