mountd: update to the latest version from 2018-02-26
authorRafał Miłecki <rafal@milecki.pl>
Mon, 26 Feb 2018 10:33:49 +0000 (11:33 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Mon, 26 Feb 2018 10:49:29 +0000 (11:49 +0100)
This significantly improves mountd stability & reliability by:
1) Sending hotplug.d event when appropriate
2) Properly unmounting
3) Handling corner cases when unmounting fails
4) Improving log messages

5f2c419 mount: drop duplicated includes
aaf2743 mount: call hotplug-call with ACTION=remove before trying to unmount
97da4ed mount: try lazy unmount if normal one fails
1b62489 mount: create not working symlink when unmounting fails
e77dc6d mount: reorder deleting code in the mount_enum_drives()
76766ae mount: rename tmp variables in the mount_add_list()
04b897f mount: drop duplicated rmdir() call from the mount_enum_drives()
a27ea3f mount: drop duplicated unlink() call from the mount_dev_del()
bf7cc33 mount: fix/improve unmounting log messages
36f9197 mount: fix removing mount point if it's expired
ed4270f mount: struct mount: replace "mounted" and "ignore" fileds with a "status"
1af9ca2 mount: change mount_dev_del() argument to struct mount *
7c8fea8 mount: rename /proc/mount parser to mount_update_mount_list()
7aadd1c mount: improve handling mounts table size

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
package/system/mountd/Makefile

index 7f6c09c1f683a7a7d4423293419edd176d9e0b23..1cae3b70a77f63729a75bdd4a49ddb846922d54a 100644 (file)
@@ -8,9 +8,9 @@ PKG_RELEASE:=4
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(LEDE_GIT)/project/mountd.git
-PKG_SOURCE_DATE:=2018-01-03
-PKG_SOURCE_VERSION:=c54e5c6e09bf8e8debea05dd0dac095624a2472b
-PKG_MIRROR_HASH:=f9fe7bed8c3cc6c1536614b4a6157a3a1bcd7e7c795979276eabc897e2400372
+PKG_SOURCE_DATE:=2018-02-26
+PKG_SOURCE_VERSION:=5f2c419109126ead730006366c6b4e83719523cf
+PKG_MIRROR_HASH:=b041afc94044a5b8cd559fecff6a47df126daa97b573a2a4c9563ed1d2223e88
 CMAKE_INSTALL:=1
 
 PKG_MAINTAINER:=John Crispin <john@phrozen.org>