kirkwood: add Linksys routers to default profile
authorLuka Perkov <luka@openwrt.org>
Wed, 11 Nov 2015 12:48:30 +0000 (12:48 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 11 Nov 2015 12:48:30 +0000 (12:48 +0000)
Signed-off-by: Claudio Leite <leitec@staticky.com>
SVN-Revision: 47458

target/linux/kirkwood/image/Makefile
target/linux/kirkwood/profiles/100-generic.mk

index 06b72240e62256f94a9f2155f2fcf119b47d7250..3fc84aa7564747ecdd5d1fcbbdba76c13c401818 100644 (file)
@@ -26,7 +26,7 @@ define Device/linksys-audi
   BLOCKSIZE := 16KiB
   KERNEL_SIZE := 2624k
   FILESYSTEMS := squashfs
   BLOCKSIZE := 16KiB
   KERNEL_SIZE := 2624k
   FILESYSTEMS := squashfs
-  PROFILES := AUDI
+  PROFILES := Generic AUDI
   IMAGES := factory.bin sysupgrade.tar
   IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
   IMAGE/sysupgrade.tar := sysupgrade-nand
   IMAGES := factory.bin sysupgrade.tar
   IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
   IMAGE/sysupgrade.tar := sysupgrade-nand
@@ -39,7 +39,7 @@ define Device/linksys-viper
   BLOCKSIZE := 128KiB
   KERNEL_SIZE := 2688k
   FILESYSTEMS := squashfs
   BLOCKSIZE := 128KiB
   KERNEL_SIZE := 2688k
   FILESYSTEMS := squashfs
-  PROFILES := VIPER
+  PROFILES := Generic VIPER
   IMAGES := factory.bin sysupgrade.tar
   IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
   IMAGE/sysupgrade.tar := sysupgrade-nand
   IMAGES := factory.bin sysupgrade.tar
   IMAGE/factory.bin := append-kernel $$$$(KERNEL_SIZE) | append-ubi
   IMAGE/sysupgrade.tar := sysupgrade-nand
index 770bbaee1b701412bd8f286df13453500e527516..f07cea80d6837e3025e7cdcab13edc4fdb39351d 100644 (file)
@@ -11,7 +11,8 @@ define Profile/Generic
        kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
        kmod-i2c-core kmod-i2c-mv64xxx \
        kmod-ata-core kmod-ata-marvell-sata \
        kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
        kmod-i2c-core kmod-i2c-mv64xxx \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-thermal-kirkwood
+       kmod-rtc-marvell kmod-thermal-kirkwood \
+       kmod-mwl8k swconfig wpad-mini
 endef
 
 define Profile/Generic/Description
 endef
 
 define Profile/Generic/Description