mac80211: b43: make B43_PHY_LP configurable
authorFelix Fietkau <nbd@openwrt.org>
Mon, 2 Jun 2014 18:17:44 +0000 (18:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 2 Jun 2014 18:17:44 +0000 (18:17 +0000)
This allows saving 11772 B if disabled.

Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
SVN-Revision: 40984

package/kernel/mac80211/Makefile

index 028929f4b6e0718ab5f4970db35d5ee25d9821b7..a328d61cefbc6c2287c8063fca0c1583abeeffd7 100644 (file)
@@ -1208,6 +1208,16 @@ define KernelPackage/b43/config
 
                  If unsure, say Y.
 
+       config PACKAGE_B43_PHY_LP
+               bool "Enable support for LP-PHYs"
+               default y
+               help
+                 Enable support for LP-PHY. This includes support for the following devices:
+                 PCI: BCM4312
+                 SoC: BCM5354
+
+                 If unsure, say Y.
+
        config PACKAGE_B43_PHY_HT
                bool "Enable support for HT-PHYs"
                default y
@@ -1418,8 +1428,9 @@ endif
 config-$(call config_package,carl9170) += CARL9170
 
 config-$(call config_package,b43) += B43
-config-y += B43_SSB B43_BCMA B43_PHY_LP
+config-y += B43_SSB B43_BCMA
 config-$(CONFIG_PACKAGE_B43_PHY_N) += B43_PHY_N
+config-$(CONFIG_PACKAGE_B43_PHY_LP) += B43_PHY_LP
 config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
 config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
 config-$(CONFIG_PACKAGE_B43_DEBUG) += B43_DEBUG