use default_subtargets in package/Makefile and target/Makefile
authorFelix Fietkau <nbd@openwrt.org>
Mon, 26 Feb 2007 00:41:53 +0000 (00:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 26 Feb 2007 00:41:53 +0000 (00:41 +0000)
SVN-Revision: 6380

package/Makefile
target/Makefile

index 6ddbc1ba45a2775319123ed381251fc4a6d65dc1..151942de343ae098e4fa56a8b53573f5c12230cc 100644 (file)
@@ -22,20 +22,7 @@ $(STAMP_DIR) $(TARGET_DIR):
 %-prereq: $(STAMP_DIR) $(TARGET_DIR)
        $(MAKE) -C $(patsubst %-prereq,%,$@) prereq
 
-%-download: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-
-%-compile: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-
-%-install: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
-%-clean: $(STAMP_DIR) $(TARGET_DIR)
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
+$(eval $(call default_subtargets,$(TARGET_DIR)))
 
 ifeq ($(SDK),1)
 GENDEP_OPTS := -s
index 724ac4450d4bff3999b881da8fbbf20beb16b8ac..1b6cbb54ee1014e6f024f8c8fba6fe1e698fd6a9 100644 (file)
@@ -51,14 +51,4 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
+$(eval $(call default_subtargets,))