include, base-files: align default repository url with changed buildbot structure
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Jan 2015 13:09:54 +0000 (13:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Jan 2015 13:09:54 +0000 (13:09 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44091

include/version.mk
package/base-files/image-config.in

index c4747f236f9b2a04f0ef825a135cb805271b78c6..c3cc170045d1723059f9239b8e9eace7e08a2425 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -30,7 +30,7 @@ VERSION_NICK:=$(call qstrip_escape,$(CONFIG_VERSION_NICK))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
 VERSION_NICK:=$(if $(VERSION_NICK),$(VERSION_NICK),$(RELEASE))
 
 VERSION_REPO:=$(call qstrip_escape,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%T/packages)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),http://downloads.openwrt.org/snapshots/trunk/%S/packages)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
 
 VERSION_DIST:=$(call qstrip_escape,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index 193ea08930a49f04623f578d80609c983a6b6bf7..fd0ead623650a6de1b07a18fab77209f98b56e54 100644 (file)
@@ -170,7 +170,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "http://downloads.openwrt.org/snapshots/trunk/%s/packages"
+               default "http://downloads.openwrt.org/snapshots/trunk/%S/packages"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders:
@@ -185,7 +185,6 @@ if VERSIONOPT
                         %d .. Distribution name or "openwrt", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
                         %d .. Distribution name or "openwrt", lowercase
                         %T .. Target name
                         %S .. Target/Subtarget name
-                        %s .. Target/Subtarget name in dotted notation, e.g. "ar71xx" or "ar71xx.nand"
                         %t .. Build taint flags, e.g. "no-all busybox"
                         %M .. Manufacturer name or "OpenWrt"
                         %P .. Product name or "Generic"
                         %t .. Build taint flags, e.g. "no-all busybox"
                         %M .. Manufacturer name or "OpenWrt"
                         %P .. Product name or "Generic"