Prevent l2tpd from using PMTU discovery, setting the DF bit on all outgoing UDP packe...
authorNicolas Thill <nico@openwrt.org>
Wed, 12 Apr 2006 00:17:43 +0000 (00:17 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 12 Apr 2006 00:17:43 +0000 (00:17 +0000)
SVN-Revision: 3621

openwrt/package/l2tpd/Makefile
openwrt/package/l2tpd/patches/05-df-disable.patch [new file with mode: 0644]

index fa1a0f948907640f5d2a2177c90e86cd05b78ce5..6435f35a7d4c31b2a1a9d33357dc6b7759a0095a 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=l2tpd
 PKG_VERSION:=0.70pre
 PKG_UPSTREAM_VERSION:=0.70-pre20031121
-PKG_RELEASE:=3.1
+PKG_RELEASE:=4.1
 PKG_MD5SUM:=3f2707b6e16a8cb72e7bf64f574202fa
 
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/l2tpd
diff --git a/openwrt/package/l2tpd/patches/05-df-disable.patch b/openwrt/package/l2tpd/patches/05-df-disable.patch
new file mode 100644 (file)
index 0000000..806c48d
--- /dev/null
@@ -0,0 +1,25 @@
+Patch to stop l2tpd setting the DF bit on each of the packets it sends.
+Apart from not being useful with L2TP, this also prevents interoperating
+with Cisco IOS over IPSEC.
+
+--- l2tpd-0.70-pre20031121.orig/network.c.orig 2006-04-11 08:50:38.000000000 +0100
++++ l2tpd-0.70-pre20031121.orig/network.c      2006-04-11 08:58:18.000000000 +0100
+@@ -56,6 +56,18 @@
+              __FUNCTION__);
+         return -EINVAL;
+     };
++#ifdef IP_MTU_DISCOVER
++#ifdef IP_PMTUDISC_DONT
++    {
++        /* Don't set DF bit on outbound packets */
++        int val = IP_PMTUDISC_DONT;
++        if (setsockopt(server_socket, IPPROTO_IP, IP_MTU_DISCOVER, &val, sizeof(val)) < 0)
++        {
++            log (LOG_LOG, "Failed to disable PMTU discovery\n");
++        }
++    }
++#endif
++#endif
+     /* L2TP/IPSec: Set up SA for listening port here?  NTB 20011015
+      */
+     if (bind (server_socket, (struct sockaddr *) &server, sizeof (server)))