kernel: bump 4.9 to 4.9.109 for 18.06
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 18 Jun 2018 12:34:16 +0000 (14:34 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 18 Jun 2018 13:28:48 +0000 (15:28 +0200)
Refreshed all patches

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0087-amba_pl011-Don-t-use-DT-aliases-for-numbering.patch
target/linux/brcm2708/patches-4.9/950-0195-amba_pl011-Round-input-clock-up.patch

index e8c0cd7b3829aea10a4ba180fc10cbc77a4c7f5f..9ee4b6b3d2e5897fa9967319aa2cd801181b2165 100644 (file)
@@ -4,13 +4,13 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .121
-LINUX_VERSION-4.9 = .108
 LINUX_VERSION-4.14 = .49
+LINUX_VERSION-4.9 = .109
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.121 = 44a88268b5088dc326b30c9b9133ac35a9a200b636b7268d08f32abeae6ca729
-LINUX_KERNEL_HASH-4.9.108 = 73fe2ba98a17962ccf249b12103b0ac3c39b298eec6696ede8d6fceee45e4041
 LINUX_KERNEL_HASH-4.14.49 = c69f49731ef392034a5d8816e2e2668bc8928878764d1c8caac37d00339d3bf7
+LINUX_KERNEL_HASH-4.9.109 = 3dcd5654a553432119492b69e649c4ed117781bfd571edcb02346c945be359b0
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 2710ed63d76a15b9539e096aea0cee6fbf37db56..a6f03468231c9ac4f3f1cc22c907eac0f09ab3aa 100644 (file)
@@ -14,7 +14,7 @@ use the same logic.
 
 --- a/drivers/tty/serial/amba-pl011.c
 +++ b/drivers/tty/serial/amba-pl011.c
-@@ -2501,7 +2501,12 @@ static int pl011_setup_port(struct devic
+@@ -2517,7 +2517,12 @@ static int pl011_setup_port(struct devic
        if (IS_ERR(base))
                return PTR_ERR(base);
  
index b981be02ac0f7be03cf7321e305dcf48796ca93d..ad532c511d3ee36b2a04345c8ed5ee4d300022bd 100644 (file)
@@ -59,7 +59,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        /* Clear pending error and receive interrupts */
        pl011_write(UART011_OEIS | UART011_BEIS | UART011_PEIS |
-@@ -2305,7 +2322,7 @@ static int __init pl011_console_setup(st
+@@ -2321,7 +2338,7 @@ static int __init pl011_console_setup(st
                        plat->init();
        }
  
@@ -68,7 +68,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  
        if (uap->vendor->fixed_options) {
                baud = uap->fixed_baud;
-@@ -2432,6 +2449,7 @@ static struct uart_driver amba_reg = {
+@@ -2448,6 +2465,7 @@ static struct uart_driver amba_reg = {
        .cons                   = AMBA_CONSOLE,
  };
  
@@ -76,7 +76,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  static int pl011_probe_dt_alias(int index, struct device *dev)
  {
        struct device_node *np;
-@@ -2463,6 +2481,7 @@ static int pl011_probe_dt_alias(int inde
+@@ -2479,6 +2497,7 @@ static int pl011_probe_dt_alias(int inde
  
        return ret;
  }