ath79: port TP-Link TL-WR741ND v4 and TL-WR740ND v4
authorRocco Folino <rocco@folino.io>
Mon, 2 Jul 2018 05:02:56 +0000 (07:02 +0200)
committerJohn Crispin <john@phrozen.org>
Mon, 2 Jul 2018 05:03:21 +0000 (07:03 +0200)
This patch ports the TP-Link TL-WR741ND v4 and TL-WR740ND v4 to the
ath79 target.

Because the two devices share the same hw layout, this patch adds a common
.dtsi which is included by the two .dts.

Signed-off-by: Rocco Folino <rocco@folino.io>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9331_tl-wr740nd-v4.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9331_tl-wr741nd-v4.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9331_tl-wr741nd-v4.dtsi [new file with mode: 0644]
target/linux/ath79/image/tiny-tp-link.mk

index 29416ad83ea7ce89f23bc065338ac98f41d5b640..3edffaff74927dba6050c8b30be7483825d50ece 100755 (executable)
@@ -45,6 +45,14 @@ case "$board" in
        ucidef_set_led_switch "lan3" "LAN3" "$boardname:green:lan3" "switch0" "0x08"
        ucidef_set_led_switch "lan4" "LAN4" "$boardname:green:lan4" "switch0" "0x10"
        ;;
+"tplink,tl-wr741nd-v4"|\
+"tplink,tl-wr740nd-v4")
+       ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x04"
+       ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
+       ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x10"
+       ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
+       ;;
 esac
 
 board_config_flush
index 579ccc5bd3206330109417d07fa4e8a5e9218d79..26b37528244f4880a188c7b1f2a6f59ad8ef6b09 100755 (executable)
@@ -70,6 +70,13 @@ ath79_setup_interfaces()
                        "0@eth1" "1:lan" "2:lan" "3:lan" "4:lan"
                ;;
 
+       "tplink,tl-wr741nd-v4"|\
+       "tplink,tl-wr740nd-v4")
+               ucidef_set_interfaces_wan "eth1"
+               ucidef_add_switch "switch0" \
+                       "0@eth0" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
+               ;;
+
        "tplink,tl-wr1043nd-v1")
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "5@eth0"
diff --git a/target/linux/ath79/dts/ar9331_tl-wr740nd-v4.dts b/target/linux/ath79/dts/ar9331_tl-wr740nd-v4.dts
new file mode 100644 (file)
index 0000000..b0029b8
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9331_tl-wr741nd-v4.dtsi"
+
+/ {
+       model = "TP-Link TL-WR740N/ND v4";
+       compatible = "tplink,tl-wr740n-v4";
+};
diff --git a/target/linux/ath79/dts/ar9331_tl-wr741nd-v4.dts b/target/linux/ath79/dts/ar9331_tl-wr741nd-v4.dts
new file mode 100644 (file)
index 0000000..118831b
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9331_tl-wr741nd-v4.dtsi"
+
+/ {
+       model = "TP-Link TL-WR741N/ND v4";
+       compatible = "tplink,tl-wr741n-v4";
+};
diff --git a/target/linux/ath79/dts/ar9331_tl-wr741nd-v4.dtsi b/target/linux/ath79/dts/ar9331_tl-wr741nd-v4.dtsi
new file mode 100644 (file)
index 0000000..615d317
--- /dev/null
@@ -0,0 +1,173 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9331.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr741n-v4", "qca,ar9331";
+       model = "TP-Link TL-WR741N/ND v4";
+
+       aliases {
+               serial0 = &uart;
+               led-status = &led_system;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "wps";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 26 GPIO_ACTIVE_HIGH>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               pinctrl-names = "default";
+               pinctrl-0 = <&switch_led_pins>;
+
+               lan1 {
+                       label = "tp-link:green:lan1";
+                       gpios = <&gpio 14 GPIO_ACTIVE_HIGH>;
+               };
+
+               lan2 {
+                       label = "tp-link:green:lan2";
+                       gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+               };
+
+               lan3 {
+                       label = "tp-link:green:lan3";
+                       gpios = <&gpio 16 GPIO_ACTIVE_HIGH>;
+               };
+
+               lan4 {
+                       label = "tp-link:green:lan4";
+                       gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               };
+
+               qss {
+                       label = "tp-link:green:qss";
+                       gpios = <&gpio 1 GPIO_ACTIVE_HIGH>;
+               };
+
+               led_system: system {
+                       label = "tp-link:green:system";
+                       gpios = <&gpio 27 GPIO_ACTIVE_HIGH>;
+               };
+
+               wan {
+                       label = "tp-link:green:wan";
+                       gpios = <&gpio 13 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan {
+                       label = "tp-link:green:wlan";
+                       gpios = <&gpio 0 GPIO_ACTIVE_HIGH>;
+                       default-state = "off";
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               reg = <0x0 0x20000>;
+                               label = "u-boot";
+                               read-only;
+                       };
+
+                       firmware: partition@20000 {
+                               reg = <0x20000 0x3d0000>;
+                               label = "firmware";
+                       };
+
+                       art: partition@3f0000 {
+                               reg = <0x3f0000 0x10000>;
+                               label = "art";
+                               read-only;
+                       };
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy4: ethernet-phy@4 {
+               reg = <4>;
+               phy-mode = "mii";
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&phy4>;
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <1>;
+
+       gmac-config {
+               device = <&gmac>;
+
+               switch-phy-addr-swap = <1>;
+               switch-phy-swap = <1>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <(-1)>;
+
+       fixed-link {
+               speed = <1000>;
+               full-duplex;
+       };
+};
+
+&gpio {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
index 0004eb20188a2e707dd27bec716029d4a642a63d..fa937b6bd560d0099c06829d9d10cd32b21d9b34 100644 (file)
@@ -60,6 +60,24 @@ define Device/tl-wr740n-v2
 endef
 TARGET_DEVICES += tl-wr740n-v2
 
+define Device/tl-wr740nd-v4
+  $(Device/tplink-4mlzma)
+  ATH_SOC := ar9331
+  DEVICE_TITLE := TP-LINK TL-WR740N/ND v4
+  TPLINK_HWID := 0x07400004
+  SUPPORTED_DEVICES := tplink,tl-wr740n-v4 tl-wr740n-v4
+endef
+TARGET_DEVICES += tl-wr740nd-v4
+
+define Device/tl-wr741nd-v4
+  $(Device/tplink-4mlzma)
+  ATH_SOC := ar9331
+  DEVICE_TITLE := TP-LINK TL-WR741N/ND v4
+  TPLINK_HWID := 0x07410004
+  SUPPORTED_DEVICES := tplink,tl-wr741n-v4 tl-wr741n-v4
+endef
+TARGET_DEVICES += tl-wr741nd-v4
+
 define Device/tl-wr841-v7
   $(Device/tplink-4m)
   ATH_SOC := ar7241