resync 2.6.30/2.6.31 patches
authorImre Kaloz <kaloz@openwrt.org>
Mon, 2 Nov 2009 09:54:06 +0000 (09:54 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 2 Nov 2009 09:54:06 +0000 (09:54 +0000)
SVN-Revision: 18270

target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch
target/linux/generic-2.6/patches-2.6.30/977-textsearch_kconfig_hacks.patch
target/linux/generic-2.6/patches-2.6.31/014-samsung_flash
target/linux/generic-2.6/patches-2.6.31/028-module_exports.patch
target/linux/generic-2.6/patches-2.6.31/230-union_mounts.patch
target/linux/generic-2.6/patches-2.6.31/801-usb_serial_endpoint_size.patch
target/linux/generic-2.6/patches-2.6.31/922-gpiommc.patch
target/linux/generic-2.6/patches-2.6.31/970-ocf_kbuild_integration.patch
target/linux/generic-2.6/patches-2.6.31/977-textsearch_kconfig_hacks.patch

index bf229eab8256a6ecb696ab285892048cb6dbea29..b24d59cfff23f414bea582d45f8cb6b42bceadff 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -784,6 +784,8 @@ config CRYPTO_ANSI_CPRNG
+@@ -778,6 +778,8 @@ config CRYPTO_ANSI_CPRNG
          for cryptographic modules.  Uses the Algorithm specified in
          ANSI X9.31 A.2.4
  
@@ -11,7 +11,7 @@
  endif # if CRYPTO
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
  obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
  
  #
index 66a86ad9955eb3748117eb293d3cdd94261b5af5..655ebae645ddc5cd97d010ad260bbdf7ac6b3d93 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -142,16 +142,16 @@ config REED_SOLOMON_DEC16
+@@ -145,16 +145,16 @@ config REED_SOLOMON_DEC16
  # Textsearch support is select'ed if needed
  #
  config TEXTSEARCH
index 5c835081b80c1f6841250aa0041ff3d09823b3d4..1faeb41eaa6e2293fa9189f81fa444f807008136 100644 (file)
@@ -8,7 +8,7 @@
  
  static int cfi_amdstd_read (struct mtd_info *, loff_t, size_t, size_t *, u_char *);
  static int cfi_amdstd_write_words(struct mtd_info *, loff_t, size_t, size_t *, const u_char *);
-@@ -386,12 +387,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
+@@ -375,12 +376,19 @@ struct mtd_info *cfi_cmdset_0002(struct 
  
                if (extp->MajorVersion != '1' ||
                    (extp->MinorVersion < '0' || extp->MinorVersion > '4')) {
index 355139e8ffb56ca2f086ebaea6416823bde4f4d4..3d73a0212f5e7b553ff78db1779415003968d18a 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.31.5/include/asm-generic/vmlinux.lds.h
-===================================================================
---- linux-2.6.31.5.orig/include/asm-generic/vmlinux.lds.h      2009-10-23 00:57:56.000000000 +0200
-+++ linux-2.6.31.5/include/asm-generic/vmlinux.lds.h   2009-10-23 12:43:50.000000000 +0200
+--- a/include/asm-generic/vmlinux.lds.h
++++ b/include/asm-generic/vmlinux.lds.h
 @@ -55,6 +55,27 @@
  #define LOAD_OFFSET 0
  #endif
@@ -86,11 +84,9 @@ Index: linux-2.6.31.5/include/asm-generic/vmlinux.lds.h
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-Index: linux-2.6.31.5/include/linux/module.h
-===================================================================
---- linux-2.6.31.5.orig/include/linux/module.h 2009-10-23 00:57:56.000000000 +0200
-+++ linux-2.6.31.5/include/linux/module.h      2009-10-23 12:43:50.000000000 +0200
-@@ -188,16 +188,24 @@
+--- a/include/linux/module.h
++++ b/include/linux/module.h
+@@ -188,16 +188,24 @@ void *__symbol_get_gpl(const char *symbo
  #define __CRC_SYMBOL(sym, sec)
  #endif
  
@@ -117,11 +113,9 @@ Index: linux-2.6.31.5/include/linux/module.h
        = { (unsigned long)&sym, __kstrtab_##sym }
  
  #define EXPORT_SYMBOL(sym)                                    \
-Index: linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S
-===================================================================
---- linux-2.6.31.5.orig/arch/arm/kernel/vmlinux.lds.S  2009-10-23 00:57:56.000000000 +0200
-+++ linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S       2009-10-23 12:43:50.000000000 +0200
-@@ -79,26 +79,6 @@
+--- a/arch/arm/kernel/vmlinux.lds.S
++++ b/arch/arm/kernel/vmlinux.lds.S
+@@ -79,26 +79,6 @@ SECTIONS
  #endif
        }
  
@@ -148,7 +142,7 @@ Index: linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S
        .text : {                       /* Real text segment            */
                _text = .;              /* Text and read-only data      */
                        __exception_text_start = .;
-@@ -205,6 +185,28 @@
+@@ -205,6 +185,28 @@ SECTIONS
                __bss_stop = .;
                _end = .;
        }
@@ -177,11 +171,9 @@ Index: linux-2.6.31.5/arch/arm/kernel/vmlinux.lds.S
                                        /* Stabs debugging sections.    */
        .stab 0 : { *(.stab) }
        .stabstr 0 : { *(.stabstr) }
-Index: linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S
-===================================================================
---- linux-2.6.31.5.orig/arch/powerpc/kernel/vmlinux.lds.S      2009-10-23 00:57:56.000000000 +0200
-+++ linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S   2009-10-23 12:43:50.000000000 +0200
-@@ -37,12 +37,6 @@
+--- a/arch/powerpc/kernel/vmlinux.lds.S
++++ b/arch/powerpc/kernel/vmlinux.lds.S
+@@ -37,12 +37,6 @@ jiffies = jiffies_64 + 4;
  #endif
  SECTIONS
  {
@@ -194,7 +186,7 @@ Index: linux-2.6.31.5/arch/powerpc/kernel/vmlinux.lds.S
        . = KERNELBASE;
  
  /*
-@@ -295,6 +289,12 @@
+@@ -295,6 +289,12 @@ SECTIONS
                __bss_stop = .;
        }
  
index 5c9d784efd245d8791ba80ba04163fb3dda185e1..b26d5fae88e0e0944eae5361c0ec51010cb5b481 100644 (file)
        if (error)
                return error;
  
-@@ -1575,6 +2409,9 @@ int may_open(struct path *path, int acc_
+@@ -1577,6 +2411,9 @@ int may_open(struct path *path, int acc_
                if (!error)
                        error = security_path_truncate(path, 0,
                                               ATTR_MTIME|ATTR_CTIME|ATTR_OPEN);
                if (!error) {
                        vfs_dq_init(inode);
  
-@@ -1621,7 +2458,7 @@ out_unlock:
+@@ -1623,7 +2460,7 @@ out_unlock:
        if (error)
                return error;
        /* Don't check for write permission, don't truncate */
  }
  
  /*
-@@ -1736,12 +2573,10 @@ struct file *do_filp_open(int dfd, const
+@@ -1738,12 +2575,10 @@ struct file *do_filp_open(int dfd, const
        if (flag & O_EXCL)
                nd.flags |= LOOKUP_EXCL;
        mutex_lock(&dir->d_inode->i_mutex);
                mutex_unlock(&dir->d_inode->i_mutex);
                goto exit;
        }
-@@ -1801,10 +2636,23 @@ do_last:
+@@ -1803,10 +2638,23 @@ do_last:
        if (path.dentry->d_inode->i_op->follow_link)
                goto do_link;
  
  ok:
        /*
         * Consider:
-@@ -1822,12 +2670,18 @@ ok:
+@@ -1824,12 +2672,18 @@ ok:
                if (error)
                        goto exit;
        }
        filp = nameidata_to_filp(&nd, open_flag);
        if (IS_ERR(filp))
                ima_counts_put(&nd.path,
-@@ -1902,8 +2756,7 @@ do_link:
+@@ -1904,8 +2758,7 @@ do_link:
        }
        dir = nd.path.dentry;
        mutex_lock(&dir->d_inode->i_mutex);
        __putname(nd.last.name);
        goto do_last;
  }
-@@ -1937,7 +2790,8 @@ EXPORT_SYMBOL(filp_open);
+@@ -1939,7 +2792,8 @@ EXPORT_SYMBOL(filp_open);
   */
  struct dentry *lookup_create(struct nameidata *nd, int is_dir)
  {
  
        mutex_lock_nested(&nd->path.dentry->d_inode->i_mutex, I_MUTEX_PARENT);
        /*
-@@ -1953,11 +2807,13 @@ struct dentry *lookup_create(struct name
+@@ -1955,11 +2809,13 @@ struct dentry *lookup_create(struct name
        /*
         * Do the final lookup.
         */
                goto eexist;
        /*
         * Special case - lookup gave negative, but... we had foo/bar/
-@@ -1966,15 +2822,17 @@ struct dentry *lookup_create(struct name
+@@ -1968,15 +2824,17 @@ struct dentry *lookup_create(struct name
         * been asking for (non-existent) directory. -ENOENT for you.
         */
        if (unlikely(!is_dir && nd->last.name[nd->last.len])) {
  }
  EXPORT_SYMBOL_GPL(lookup_create);
  
-@@ -2086,6 +2944,7 @@ SYSCALL_DEFINE3(mknod, const char __user
+@@ -2088,6 +2946,7 @@ SYSCALL_DEFINE3(mknod, const char __user
  int vfs_mkdir(struct inode *dir, struct dentry *dentry, int mode)
  {
        int error = may_create(dir, dentry);
  
        if (error)
                return error;
-@@ -2099,9 +2958,18 @@ int vfs_mkdir(struct inode *dir, struct 
+@@ -2101,9 +2960,18 @@ int vfs_mkdir(struct inode *dir, struct 
                return error;
  
        vfs_dq_init(dir);
        return error;
  }
  
-@@ -2147,6 +3015,212 @@ SYSCALL_DEFINE2(mkdir, const char __user
+@@ -2149,6 +3017,212 @@ SYSCALL_DEFINE2(mkdir, const char __user
        return sys_mkdirat(AT_FDCWD, pathname, mode);
  }
  
  /*
   * We try to drop the dentry early: we should have
   * a usage count of 2 if we're the only user of this
-@@ -2211,7 +3285,7 @@ static long do_rmdir(int dfd, const char
+@@ -2213,7 +3287,7 @@ static long do_rmdir(int dfd, const char
  {
        int error = 0;
        char * name;
        struct nameidata nd;
  
        error = user_path_parent(dfd, pathname, &nd, &name);
-@@ -2233,21 +3307,24 @@ static long do_rmdir(int dfd, const char
+@@ -2235,21 +3309,24 @@ static long do_rmdir(int dfd, const char
        nd.flags &= ~LOOKUP_PARENT;
  
        mutex_lock_nested(&nd.path.dentry->d_inode->i_mutex, I_MUTEX_PARENT);
  exit2:
        mutex_unlock(&nd.path.dentry->d_inode->i_mutex);
  exit1:
-@@ -2302,7 +3379,7 @@ static long do_unlinkat(int dfd, const c
+@@ -2304,7 +3381,7 @@ static long do_unlinkat(int dfd, const c
  {
        int error;
        char *name;
        struct nameidata nd;
        struct inode *inode = NULL;
  
-@@ -2317,26 +3394,29 @@ static long do_unlinkat(int dfd, const c
+@@ -2319,26 +3396,29 @@ static long do_unlinkat(int dfd, const c
        nd.flags &= ~LOOKUP_PARENT;
  
        mutex_lock_nested(&nd.path.dentry->d_inode->i_mutex, I_MUTEX_PARENT);
        }
        mutex_unlock(&nd.path.dentry->d_inode->i_mutex);
        if (inode)
-@@ -2347,8 +3427,8 @@ exit1:
+@@ -2349,8 +3429,8 @@ exit1:
        return error;
  
  slashes:
        goto exit2;
  }
  
-@@ -2684,11 +3764,96 @@ int vfs_rename(struct inode *old_dir, st
+@@ -2686,11 +3766,96 @@ int vfs_rename(struct inode *old_dir, st
        return error;
  }
  
        struct dentry *trap;
        struct nameidata oldnd, newnd;
        char *from;
-@@ -2722,16 +3887,28 @@ SYSCALL_DEFINE4(renameat, int, olddfd, c
+@@ -2724,16 +3889,28 @@ SYSCALL_DEFINE4(renameat, int, olddfd, c
  
        trap = lock_rename(new_dir, old_dir);
  
                error = -ENOTDIR;
                if (oldnd.last.name[oldnd.last.len])
                        goto exit4;
-@@ -2740,32 +3917,44 @@ SYSCALL_DEFINE4(renameat, int, olddfd, c
+@@ -2742,32 +3919,44 @@ SYSCALL_DEFINE4(renameat, int, olddfd, c
        }
        /* source should not be ancestor of target */
        error = -EINVAL;
index 6f0262538194fca81006802d2b8228d738fd2cf7..41b3848f4d26a407b0abb76c7676066ef78297cb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/serial/usb-serial.c
 +++ b/drivers/usb/serial/usb-serial.c
-@@ -62,6 +62,7 @@ static struct usb_driver usb_serial_driv
+@@ -60,6 +60,7 @@ static struct usb_driver usb_serial_driv
     drivers depend on it.
  */
  
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -946,7 +947,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -947,7 +948,7 @@ int usb_serial_probe(struct usb_interfac
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1416,3 +1417,5 @@ MODULE_LICENSE("GPL");
+@@ -1381,3 +1382,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 9375823f5d87a211f7203e9a2d2c4287d6ba5985..512a0b196c06ab8c9dbe797abe547e7307f06006 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -2260,6 +2260,11 @@ T:      git git://git.kernel.org/pub/scm/linu
+@@ -2266,6 +2266,11 @@ T:      git git://git.kernel.org/pub/scm/linu
  S:    Maintained
  F:    drivers/media/video/gspca/
  
index 54740df0838c041e264280ecef728471ea752c4e..a6d86ce44aac3378bab59914bb3193604e4036ef 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -794,6 +794,8 @@ config CRYPTO_ANSI_CPRNG
+@@ -788,6 +788,8 @@ config CRYPTO_ANSI_CPRNG
          for cryptographic modules.  Uses the Algorithm specified in
          ANSI X9.31 A.2.4
  
@@ -11,7 +11,7 @@
  endif # if CRYPTO
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
  obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
  
  #
index 655ebae645ddc5cd97d010ad260bbdf7ac6b3d93..97fad7dfeb6a5bcfe01112d88c6e825f21f8a2e0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/Kconfig
 +++ b/lib/Kconfig
-@@ -145,16 +145,16 @@ config REED_SOLOMON_DEC16
+@@ -148,16 +148,16 @@ config REED_SOLOMON_DEC16
  # Textsearch support is select'ed if needed
  #
  config TEXTSEARCH