block-mount: add a delay between sto pand start in fstab init restart action, fixes...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 19 Dec 2012 09:41:28 +0000 (09:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 19 Dec 2012 09:41:28 +0000 (09:41 +0000)
SVN-Revision: 34784

package/block-mount/Makefile
package/block-mount/files/fstab.init

index 799539e4bd53cd58e4d7b8091f7b3d619db92f27..06deb9401d3c0a246156369850edd0c6e165ce02 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=block-mount
 PKG_VERSION:=0.2.0
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 
 include $(INCLUDE_DIR)/package.mk
 
index f54051ebb7f06c0ceebf8f09a77007778ff51b21..4f1f6fb7a097fb9d416cf5d32b379448ac70633c 100644 (file)
@@ -85,4 +85,8 @@ stop() {
        swapoff -a
 }
 
-
+restart() {
+       stop
+       sleep 1
+       start
+}