ar71xx: build TP-LINK Archer C7 images with US region code
authorJohn Crispin <john@openwrt.org>
Thu, 21 Apr 2016 19:47:22 +0000 (19:47 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 21 Apr 2016 19:47:22 +0000 (19:47 +0000)
Since December 2015, the Archer C7 comes with an US-specific firmware. This
firmware will only allow upgrades with images that contain the US region
code in the firmware header.

The "universal" firmware distributed in the rest of the world doesn't care
about the region code, so we can just unconditionally set the region to US
for now. When other region-specific firmwares appear, we'll need to create
a factory image for each of them.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
SVN-Revision: 49217

target/linux/ar71xx/image/Makefile

index 2699b64878f48ae09dcc2ebb14122b92a34167bd..2b2e868822eaf6799d4d78b4f6351b2b803b0c83 100644 (file)
@@ -414,6 +414,7 @@ define Device/archer-c7-v2
     BOARDNAME := ARCHER-C7
     DEVICE_PROFILE := ARCHERC7
     TPLINK_HWID := 0xc7000002
+    IMAGE/factory.bin := append-rootfs | mktplinkfw factory -C US
 endef
 
 define Device/tl-wdr7500-v3