ar71xx, ramips: reduce CPU load and flickering on devices using rsslieds
authorMartin Weinelt <martin@darmstadt.freifunk.net>
Wed, 2 Nov 2016 15:10:44 +0000 (16:10 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Wed, 16 Nov 2016 00:42:15 +0000 (01:42 +0100)
Polling every 40ms causes more than 10% CPU load on weak devices. An
interval of 200ms is much more reasonable.

Signed-off-by: Martin Weinelt <martin@darmstadt.freifunk.net>
[Matthias Schiffer: adapt OpenWrt patch; add ramips; extend commit message]
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/01_leds

index cde3a94..1708abf 100755 (executable)
@@ -21,7 +21,7 @@ alfa-nx)
        ;;
 all0258n|\
 all0315n)
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "$board:red:rssilow" "wlan0" "1" "40" "0" "6"
        ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "$board:yellow:rssimedium" "wlan0" "30" "80" "-29" "5"
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$board:green:rssihigh" "wlan0" "70" "100" "-69" "8"
@@ -115,7 +115,7 @@ cpe210|\
 cpe510)
        ucidef_set_led_switch "lan0" "LAN0" "tp-link:green:lan0" "switch0" "0x20"
        ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:link1" "wlan0" "1" "100" "0" "13"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:link2" "wlan0" "26" "100" "-25" "13"
        ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:link3" "wlan0" "51" "100" "-50" "13"
@@ -307,7 +307,7 @@ mynet-n600)
        ;;
 mynet-rext)
        ucidef_set_led_netdev "lan" "LAN" "wd:blue:ethernet" "eth0"
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "wd:blue:quality1" "wlan0" "1" "40" "0" "6"
        ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "wd:blue:quality2" "wlan0" "30" "80" "-29" "5"
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "wd:blue:quality3" "wlan0" "70" "100" "-69" "8"
@@ -445,7 +445,7 @@ tl-wr941nd-v5)
        ;;
 tl-wa7210n-v2)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:signal1" "wlan0" "1" "100" "0" "13"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:signal2" "wlan0" "26" "100" "-25" "13"
        ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:signal3" "wlan0" "51" "100" "-50" "13"
@@ -454,7 +454,7 @@ tl-wa7210n-v2)
 tl-wa750re)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:orange:lan" "eth0"
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:orange:wlan" "phy0tpt"
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:orange:signal1" "wlan0" "1" "100" "0" "13"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:orange:signal2" "wlan0" "20" "100" "-19" "13"
        ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "tp-link:orange:signal3" "wlan0" "40" "100" "-39" "13"
@@ -464,7 +464,7 @@ tl-wa750re)
 tl-wa850re)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:blue:lan" "eth0"
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:blue:wlan" "phy0tpt"
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:blue:signal1" "wlan0" "1" "100" "0" "13"
        ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:blue:signal2" "wlan0" "20" "100" "-19" "13"
        ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "tp-link:blue:signal3" "wlan0" "40" "100" "-39" "13"
@@ -563,7 +563,7 @@ tl-wr2543n)
        ;;
 tube2h)
        ucidef_set_led_netdev "lan" "LAN" "alfa:blue:lan" "eth0"
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "signal1" "SIGNAL1" "alfa:red:signal1" "wlan0" "1" "100" "0" "13"
        ucidef_set_led_rssi "signal2" "SIGNAL2" "alfa:orange:signal2" "wlan0" "26" "100" "-25" "13"
        ucidef_set_led_rssi "signal3" "SIGNAL3" "alfa:green:signal3" "wlan0" "51" "100" "-50" "13"
index 8d6bb45..0f1ad57 100755 (executable)
@@ -54,7 +54,7 @@ wf-2881)
        set_usb_led "$board:green:usb"
        ;;
 all0256n)
-       ucidef_set_rssimon "wlan0" "40000" "1"
+       ucidef_set_rssimon "wlan0" "200000" "1"
        ucidef_set_led_rssi "rssilow" "RSSILOW" "$board:green:rssilow" "wlan0" "1" "40" "0" "6"
        ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "$board:green:rssimed" "wlan0" "30" "80" "-29" "5"
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$board:green:rssihigh" "wlan0" "70" "100" "-69" "8"
@@ -313,7 +313,7 @@ whr-600d)
        ucidef_set_led_default "router" "router" "$board:green:router" "1"
        ;;
 wl-wn575a3)
-       ucidef_set_rssimon "wlan1" "40000" "1"
+       ucidef_set_rssimon "wlan1" "200000" "1"
        ucidef_set_led_rssi "wifi-low" "wifi-low" "$board:green:wifi-low" "wlan1" "1" "49" "0" "1"
        ucidef_set_led_rssi "wifi-med" "wifi-med" "$board:green:wifi-med" "wlan1" "50" "84" "0" "1"
        ucidef_set_led_rssi "wifi-high" "wifi-high" "$board:green:wifi-high" "wlan1" "85" "100" "0" "1"