brcm2708: restore UART on RPi 0W, 3B, 3B+ and 4B
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 3 Sep 2019 11:01:50 +0000 (13:01 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Tue, 3 Sep 2019 17:37:29 +0000 (19:37 +0200)
Disable Bluetooth and restore UART to GPIOs 14 & 15.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/brcm2708/image/Makefile
target/linux/brcm2708/image/config-bcm2711-arm64.txt
target/linux/brcm2708/image/config.txt
target/linux/brcm2708/image/distroconfig.txt [new file with mode: 0644]

index f1a4bb8dc49cfdf7d4020ecbcffdf9a7367d70e1..97f127d3077be53c72c379aa05e22e4b62aea706 100644 (file)
@@ -28,6 +28,7 @@ define Build/boot-common
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
+       mcopy -i $@.boot distroconfig.txt ::
        mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_IMG)
        $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
index 1af8ed0dfee4cad12c8db51fdb9f8179e1a2460a..984aab585e8245797dfacf3f8c002fa95c567ed7 100644 (file)
@@ -9,3 +9,9 @@
 
 # Force aarch64
 arm_64bit=1
+
+# OpenWrt config
+include distroconfig.txt
+
+[all]
+# Place your custom settings here.
index 0b963a99ae06cb69db642c8db759ad597957453d..f8ca1bf2d492781bb3cec9be13c6f637095c86c8 100644 (file)
@@ -6,3 +6,9 @@
 # For overclocking and various other settings, see:
 # https://www.raspberrypi.org/documentation/configuration/config-txt/README.md
 ################################################################################
+
+# OpenWrt config
+include distroconfig.txt
+
+[all]
+# Place your custom settings here.
diff --git a/target/linux/brcm2708/image/distroconfig.txt b/target/linux/brcm2708/image/distroconfig.txt
new file mode 100644 (file)
index 0000000..54cf443
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+# Bootloader configuration - distroconfig.txt
+################################################################################
+
+# Restore PL011 (ttyAMA0) to GPIOs 14 & 15, instead of Mini UART (ttyS0).
+# Mini UART is disabled by default unless "enable_uart=1" is specified,
+#  which changes the core frequency to a fixed value and impacts performance.
+# See https://www.raspberrypi.org/documentation/configuration/uart.md
+[pi0w]
+dtoverlay=disable-bt
+[pi3]
+dtoverlay=disable-bt
+[pi4]
+dtoverlay=disable-bt