ramips: allow JCG_MAXSIZE in kiB in Build/jcg-header
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 12 Dec 2019 19:26:06 +0000 (20:26 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 13 Dec 2019 18:54:14 +0000 (19:54 +0100)
This allows JCG_MAXSIZE to be specified in kilobytes. This makes
this value more consistent and easier comparable with other size
variables.

This also changes the only occurence of the variable, for Cudy WR1000.

This is backported to 19.07 for convenience, as other developers
backporting device support might not be aware that JCG_MAXSIZE in
kilobytes would not work there.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
(cherry picked from commit 0bf4d681d4f2e4bd3c3a61e7fe5dca2a40b1902f)

target/linux/ramips/image/Makefile
target/linux/ramips/image/mt76x8.mk

index 07251aebbad781592d121c244f12c977cdfc2aba..f51e337afdab5997f6bf93a3834804a8da4ec69d 100644 (file)
@@ -48,7 +48,9 @@ define Device/seama
 endef
 
 define Build/jcg-header
-       $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) $(if $(JCG_MAXSIZE), -m $(JCG_MAXSIZE),) -u $@ -o $@.new
+       $(STAGING_DIR_HOST)/bin/jcgimage -v $(1) \
+               $(if $(JCG_MAXSIZE), -m $$(($(subst k, * 1024,$(JCG_MAXSIZE)))),) \
+               -u $@ -o $@.new
        mv $@.new $@
 endef
 
index 054935e5957fa2b13ea81deb65a95c3d97b50dcd..7df5c04297693263098549d445ece3fed5d9aba0 100644 (file)
@@ -33,7 +33,7 @@ define Device/cudy_wr1000
   IMAGES += factory.bin
   IMAGE/factory.bin := \
         $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | jcg-header 92.122
-  JCG_MAXSIZE := 8060928
+  JCG_MAXSIZE := 7872k
   DEVICE_TITLE := Cudy WR1000
   DEVICE_PACKAGES := kmod-mt76x2
   SUPPORTED_DEVICES += wr1000