kernel: bump 4.14 to 4.14.111
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 11:39:00 +0000 (13:39 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 12:53:39 +0000 (14:53 +0200)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/021-0004-crypto-crypto4xx-kill-MODULE_NAME.patch
target/linux/ar71xx/patches-4.14/930-chipidea-pullup.patch
target/linux/brcm2708/patches-4.14/950-0056-fbdev-add-FBIOCOPYAREA-ioctl.patch
target/linux/brcm2708/patches-4.14/950-0136-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch
target/linux/generic/backport-4.14/320-v4.16-netfilter-nf_conntrack-add-IPS_OFFLOAD-status-bit.patch
target/linux/generic/backport-4.14/370-netfilter-nf_flow_table-fix-offloaded-connection-tim.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/layerscape/patches-4.14/812-flexspi-support-layerscape.patch

index dd568c12bb571137615c4f99c028ac86d35c1e7a..3d8e85abe228860c26d5f46d496025b8164bbf48 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .168
-LINUX_VERSION-4.14 = .110
+LINUX_VERSION-4.14 = .111
 LINUX_VERSION-4.19 = .25
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.168 = 4d451c21effad77de323edc9bfeae095aa1faed1a801ef427d66f5763bef091e
-LINUX_KERNEL_HASH-4.14.110 = 99ea359464dc8a7ab9862195934a1f3504c38a32af5fa424e3ae56244dd59e72
+LINUX_KERNEL_HASH-4.14.111 = f8197d56553f864d1d2e97abbe4fca50f8ab5e72089c292d22f0e4395340a6e8
 LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 4ee99f44cfd1cb397b698f86fc5cde53d2d6861d..87d7a3e67473701fb0223e840f26a4d8873169e0 100644 (file)
@@ -36,7 +36,7 @@ Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
  #define PPC460EX_SDR0_SRST                      0x201
 --- a/drivers/crypto/amcc/crypto4xx_trng.c
 +++ b/drivers/crypto/amcc/crypto4xx_trng.c
-@@ -92,7 +92,7 @@ void ppc4xx_trng_probe(struct crypto4xx_
+@@ -94,7 +94,7 @@ void ppc4xx_trng_probe(struct crypto4xx_
        if (!rng)
                goto err_out;
  
index 6e293305dbe1f5609db2ba4cd142d9c9ba1066b4..2e9a878630270d4a584d6cbe51916e5ec1f727a8 100644 (file)
@@ -37,7 +37,7 @@
        ret = hw_device_init(ci, base);
        if (ret < 0) {
                dev_err(dev, "can't initialize hardware\n");
-@@ -1004,7 +1007,7 @@ static int ci_hdrc_probe(struct platform
+@@ -1011,7 +1014,7 @@ static int ci_hdrc_probe(struct platform
                goto deinit_gadget;
        }
  
index dd41f5d44e32e7435c2c5d64243599e96c9225ae..242fa50d9c52610fb198a64e1d6c920594b3b2bb 100644 (file)
@@ -170,7 +170,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
                platform_set_drvdata(dev, fb);
 --- a/drivers/video/fbdev/core/fbmem.c
 +++ b/drivers/video/fbdev/core/fbmem.c
-@@ -1090,6 +1090,31 @@ fb_blank(struct fb_info *info, int blank
+@@ -1093,6 +1093,31 @@ fb_blank(struct fb_info *info, int blank
  }
  EXPORT_SYMBOL(fb_blank);
  
@@ -202,7 +202,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
  static long do_fb_ioctl(struct fb_info *info, unsigned int cmd,
                        unsigned long arg)
  {
-@@ -1100,6 +1125,7 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1103,6 +1128,7 @@ static long do_fb_ioctl(struct fb_info *
        struct fb_cmap cmap_from;
        struct fb_cmap_user cmap;
        struct fb_event event;
@@ -210,7 +210,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        void __user *argp = (void __user *)arg;
        long ret = 0;
  
-@@ -1217,6 +1243,15 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1220,6 +1246,15 @@ static long do_fb_ioctl(struct fb_info *
                unlock_fb_info(info);
                console_unlock();
                break;
@@ -226,7 +226,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        default:
                if (!lock_fb_info(info))
                        return -ENODEV;
-@@ -1362,6 +1397,7 @@ static long fb_compat_ioctl(struct file
+@@ -1365,6 +1400,7 @@ static long fb_compat_ioctl(struct file
        case FBIOPAN_DISPLAY:
        case FBIOGET_CON2FBMAP:
        case FBIOPUT_CON2FBMAP:
index 9011de8b96513930f7a8913a7dfb346e31c00f90..eb85fe6439804feffa2e10b4d46f134b7b04996a 100644 (file)
@@ -39,7 +39,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -5580,6 +5588,28 @@ static int __init cgroup_disable(char *s
+@@ -5583,6 +5591,28 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index fcf54e9858da10ef9963e6e204f82581d52e41ac..007b8315e529dc8afd1f73464b1ecbd422701c13 100644 (file)
@@ -92,7 +92,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  #endif
 --- a/net/bridge/br_netfilter_hooks.c
 +++ b/net/bridge/br_netfilter_hooks.c
-@@ -992,7 +992,7 @@ int br_nf_hook_thresh(unsigned int hook,
+@@ -987,7 +987,7 @@ int br_nf_hook_thresh(unsigned int hook,
        unsigned int i;
        int ret;
  
index 00303f90a1ae1e54ba70890b2f46888512015e42..53993ffe56372e215aff1b3ec94a6a2b23609a6a 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  };
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -917,6 +917,9 @@ static unsigned int early_drop_list(stru
+@@ -925,6 +925,9 @@ static unsigned int early_drop_list(stru
        hlist_nulls_for_each_entry_rcu(h, n, head, hnnode) {
                tmp = nf_ct_tuplehash_to_ctrack(h);
  
@@ -57,7 +57,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                if (nf_ct_is_expired(tmp)) {
                        nf_ct_gc_expired(tmp);
                        continue;
-@@ -994,6 +997,18 @@ static bool gc_worker_can_early_drop(con
+@@ -1002,6 +1005,18 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1030,6 +1045,11 @@ static void gc_worker(struct work_struct
+@@ -1038,6 +1053,11 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 166b7219d592b5d653775056c96f30ae9fc6d0a3..22fdebb3a8fad9558e6ac382f467440f4d3ae19f 100644 (file)
@@ -21,7 +21,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -997,18 +997,6 @@ static bool gc_worker_can_early_drop(con
+@@ -1005,18 +1005,6 @@ static bool gc_worker_can_early_drop(con
        return false;
  }
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static void gc_worker(struct work_struct *work)
  {
        unsigned int min_interval = max(HZ / GC_MAX_BUCKETS_DIV, 1u);
-@@ -1045,10 +1033,8 @@ static void gc_worker(struct work_struct
+@@ -1053,10 +1041,8 @@ static void gc_worker(struct work_struct
                        tmp = nf_ct_tuplehash_to_ctrack(h);
  
                        scanned++;
index 94553805685af2491afdb39dadd0280c5a201d1b..99e3b5e3445e3718136d1ba35a44b1c9f74b9280 100644 (file)
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2770,6 +2770,8 @@ static const struct file_operations proc
+@@ -2774,6 +2774,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {
index b5cbb4096f9fb32d93cc0cee090542ac65550751..333dc9f3d5054ebae9d7cd50f0a51cbdd7259ec9 100644 (file)
@@ -440,9 +440,9 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        irq = dwc3_gadget_get_irq(dwc);
        if (irq < 0) {
-@@ -3286,6 +3287,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
-               goto err4;
-       }
+@@ -3288,6 +3289,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+       dwc3_gadget_set_speed(&dwc->gadget, dwc->maximum_speed);
  
 +      if (dwc->disable_devinit_u1u2_quirk) {
 +              reg = dwc3_readl(dwc->regs, DWC3_DCTL);
index 0619431211e92eb11f83cf14eb1004d3ecf1f9fe..e08cbb4881660d761f3f2887a35a1adca67282a4 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
 
 --- a/drivers/md/dm-thin.c
 +++ b/drivers/md/dm-thin.c
-@@ -3690,6 +3690,19 @@ static int process_create_thin_mesg(unsi
+@@ -3697,6 +3697,19 @@ static int process_create_thin_mesg(unsi
                return r;
        }