iproute2: honor LDFLAGS
authorSteven Barth <cyrus@openwrt.org>
Fri, 19 Jun 2015 13:30:18 +0000 (13:30 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 19 Jun 2015 13:30:18 +0000 (13:30 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46064

package/network/utils/iproute2/Makefile

index 308ec578e12292b80865f09565631d56be22ab1c..7b55f695e8db13633b359d52a24e50952f383831 100644 (file)
@@ -95,7 +95,7 @@ MAKE_FLAGS += \
        EXTRA_CCOPTS="$(TARGET_CFLAGS) -I../include -I$(STAGING_DIR)/usr/include/libnl-tiny" \
        KERNEL_INCLUDE="$(LINUX_DIR)/include" \
        SHARED_LIBS="" \
-       LDFLAGS="-Wl,--gc-sections" \
+       LDFLAGS="$(TARGET_LDFLAGS) -Wl,--gc-sections" \
        IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
        FPIC="$(FPIC)"