toolchain: use latest glibc 2.21 and 2.22 revisions
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Feb 2016 08:44:49 +0000 (08:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Feb 2016 08:44:49 +0000 (08:44 +0000)
Refresh patches and rework Makefile to fetch glibc from release branches
instead of relying on tarballs.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 48735

toolchain/glibc/Config.version
toolchain/glibc/common.mk
toolchain/glibc/patches/2.21/200-add-dl-search-paths.patch
toolchain/glibc/patches/2.22/200-add-dl-search-paths.patch

index 99ab7fd43180bdd8fee90b55354abe7b6014bdc5..360045336dbdf67904b949fecb3a5aa21a40c43d 100644 (file)
@@ -16,12 +16,6 @@ config GLIBC_VERSION_2_22
        default y if !TOOLCHAINOPTS
        bool
 
        default y if !TOOLCHAINOPTS
        bool
 
-config GLIBC_REVISION
-       string
-       default "25243" if EGLIBC_VERSION_2_19
-       default "4e42b5b8f8" if GLIBC_VERSION_2_21
-       default ""
-
 endif
 
 menu "eglibc configuration"
 endif
 
 menu "eglibc configuration"
index 14063bf9df2843a66b182f44f41174542065079c..042e63d51041d5d55726b5d54e387573ac2cf0f6 100644 (file)
@@ -1,27 +1,33 @@
 #
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
+
+MD5SUM_2.19 = 42dad4edd3bcb38006d13b5640b00b38
+REVISION_2.19 = 25243
+
+MD5SUM_2.21 = 76050a65c444d58b5c4aa0d6034736ed
+REVISION_2.21 = 16d0a0c
+
+MD5SUM_2.22 = b575850e77b37d70f96472285290b391
+REVISION_2.22 = b995d95
+
+
 PKG_NAME:=glibc
 PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
 
 PKG_NAME:=glibc
 PKG_VERSION:=$(call qstrip,$(CONFIG_GLIBC_VERSION))
 
-ifeq ($(PKG_VERSION),2.22)
-  PKG_SOURCE_URL:=http://ftpmirror.gnu.org/libc
-  PKG_MD5SUM:=eb731406903befef1d8f878a46be75ef862b9056ab0cde1626d08a7a05328948
-  PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-  PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.xz
-else
-  PKG_REVISION:=$(call qstrip,$(CONFIG_GLIBC_REVISION))
-  PKG_SOURCE_PROTO:=git
-  PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
-  PKG_SOURCE_VERSION:=$(PKG_REVISION)
-  PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
-  PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
-endif
+PKG_REVISION:=$(REVISION_$(PKG_VERSION))
+PKG_MIRROR_MD5SUM:=$(MD5SUM_$(PKG_VERSION))
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://sourceware.org/git/glibc.git
+PKG_SOURCE_VERSION:=$(PKG_REVISION)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REVISION)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
 
 GLIBC_PATH:=
 ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
 
 GLIBC_PATH:=
 ifneq ($(CONFIG_EGLIBC_VERSION_2_19),)
index a6200f783b7030c4a1459f2a0fb1755874df1c19..070f938fe363093cd7e899c6696ade7d579be74d 100644 (file)
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
 
 --- a/Makeconfig
 +++ b/Makeconfig
 
 --- a/Makeconfig
 +++ b/Makeconfig
-@@ -501,6 +501,9 @@ else
+@@ -499,6 +499,9 @@ else
  default-rpath = $(libdir)
  endif
  
  default-rpath = $(libdir)
  endif
  
index a6200f783b7030c4a1459f2a0fb1755874df1c19..d82686c079536258aed45de354dc5d6d717f23d8 100644 (file)
@@ -2,7 +2,7 @@ add /usr/lib to default search path for the dynamic linker
 
 --- a/Makeconfig
 +++ b/Makeconfig
 
 --- a/Makeconfig
 +++ b/Makeconfig
-@@ -501,6 +501,9 @@ else
+@@ -527,6 +527,9 @@ else
  default-rpath = $(libdir)
  endif
  
  default-rpath = $(libdir)
  endif