kernel: add disabled CONFIG_IP6_NF_TARGET_MASQUERADE
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 2 Nov 2020 16:33:01 +0000 (17:33 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 2 Nov 2020 17:14:20 +0000 (18:14 +0100)
In kernel commit adf82accc5f5 ("netfilter: x_tables: merge ip and
ipv6 masquerade modules") the config symbols IP_NF_TARGET_MASQUERADE
and IP6_NF_TARGET_MASQUERADE have been demoted to simple backwards-
compat options for NETFILTER_XT_TARGET_MASQUERADE.

In netfilter.mk, this has already been updated in OpenWrt commit
d1592306cc07 ("netfilter.mk: use CONFIG_NETFILTER_XT_TARGET_MASQUERADE"),
having us use the new config symbol.

However, enabling IP_NF_NAT or IP6_NF_NAT still makes the relevant
legacy options selectable, so we need to disable them in generic
config (and forget about them afterwards).
Since CONFIG_IP_NF_TARGET_MASQUERADE is already present there, this
just adds the missing CONFIG_IP6_NF_TARGET_MASQUERADE.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/generic/config-5.4

index 0be228855081acdce000e903f68cff6aca1e6d38..296e875a19f2a943f54deaf755932217d4f3e15d 100644 (file)
@@ -2380,6 +2380,7 @@ CONFIG_IO_STRICT_DEVMEM=y
 # CONFIG_IP6_NF_RAW is not set
 # CONFIG_IP6_NF_SECURITY is not set
 # CONFIG_IP6_NF_TARGET_HL is not set
+# CONFIG_IP6_NF_TARGET_MASQUERADE is not set
 # CONFIG_IP6_NF_TARGET_REJECT is not set
 # CONFIG_IP6_NF_TARGET_SYNPROXY is not set
 # CONFIG_IPACK_BUS is not set