net5501: correct net5501 h/w configuration Bump to version 3.2. Simplify and correct...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 2 Feb 2012 18:41:10 +0000 (18:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 2 Feb 2012 18:41:10 +0000 (18:41 +0000)
SVN-Revision: 29994

target/linux/x86/net5501/base-files/etc/config/network [new file with mode: 0644]
target/linux/x86/net5501/base-files/etc/config/system [new file with mode: 0644]
target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot [new file with mode: 0644]
target/linux/x86/net5501/config-default
target/linux/x86/net5501/target.mk

diff --git a/target/linux/x86/net5501/base-files/etc/config/network b/target/linux/x86/net5501/base-files/etc/config/network
new file mode 100644 (file)
index 0000000..c0b6230
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright (C) 2011 OpenWrt.org
+
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   "eth1 eth2 eth3"
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
+
+config interface wan
+       option ifname   eth0
+       option proto    dhcp
diff --git a/target/linux/x86/net5501/base-files/etc/config/system b/target/linux/x86/net5501/base-files/etc/config/system
new file mode 100644 (file)
index 0000000..5db7bc2
--- /dev/null
@@ -0,0 +1,16 @@
+config system
+       option hostname OpenWrt
+       option timezone UTC
+
+config timeserver ntp
+       list server     0.openwrt.pool.ntp.org
+       list server     1.openwrt.pool.ntp.org
+       list server     2.openwrt.pool.ntp.org
+       list server     3.openwrt.pool.ntp.org
+
+config led
+       option default  1
+       option name     Heartbeat
+       option sysfs    'net5501:1'
+       option trigger  heartbeat
+
diff --git a/target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot b/target/linux/x86/net5501/base-files/etc/hotplug.d/button/50-reboot
new file mode 100644 (file)
index 0000000..bf893c1
--- /dev/null
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+logger -t button -p daemon.info "$BUTTON/$ACTION"
+
+case "$BUTTON/$ACTION" in
+
+reset/released)
+  reboot -f
+  ;;
+
+esac
+
+exit 0
index 173602794b7daaa37391fa83949b252cbf234b44..b581e95d618527201d78cbec49e75c37e1d13637 100644 (file)
@@ -1,42 +1,25 @@
-CONFIG_ARCH_HWEIGHT_CFLAGS="-fcall-saved-ecx -fcall-saved-edx"
-CONFIG_CPU_SUP_AMD=y
+# CONFIG_AMD_NB is not set
+# CONFIG_ATA_PIIX is not set
 CONFIG_DEBUG_BUGVERBOSE=y
+# CONFIG_FB_GEODE is not set
 CONFIG_GENERIC_GPIO=y
 CONFIG_GPIOLIB=y
 CONFIG_GPIO_SYSFS=y
-CONFIG_HAVE_EARLY_RES=y
-CONFIG_HAVE_HW_BREAKPOINT=y
-CONFIG_HAVE_MIXED_BREAKPOINTS_REGS=y
-CONFIG_HAVE_OPTPROBES=y
-CONFIG_HAVE_PERF_EVENTS=y
-CONFIG_HAVE_REGS_AND_STACK_ACCESS_API=y
-CONFIG_HAVE_USER_RETURN_NOTIFIER=y
+# CONFIG_HIGHMEM64G is not set
 CONFIG_HWMON=y
 # CONFIG_HWMON_DEBUG_CHIP is not set
-CONFIG_ILLEGAL_POINTER_VALUE=0
-CONFIG_INSTRUCTION_DECODER=y
-CONFIG_ISA_DMA_API=y
-CONFIG_K8_NB=y
+# CONFIG_ISDN is not set
 # CONFIG_LEDS_GPIO is not set
 # CONFIG_M486 is not set
+# CONFIG_MATH_EMULATION is not set
 CONFIG_MGEODE_LX=y
-CONFIG_GEODE_MFGPT_TIMER=y
-# CONFIG_NEED_DMA_MAP_STATE is not set
-CONFIG_NEED_SG_DMA_LENGTH=y
-# CONFIG_PCIEPORTBUS is not set
-# CONFIG_PCSPKR_PLATFORM is not set
-CONFIG_PERF_EVENTS=y
-CONFIG_PROCESSOR_SELECT=y
-CONFIG_SCSI_MOD=y
+CONFIG_NET5501=y
+CONFIG_PATA_CS5536=y
+# CONFIG_POWER_SUPPLY is not set
 # CONFIG_SCx200 is not set
 # CONFIG_SERIO_I8042 is not set
 # CONFIG_SERIO_LIBPS2 is not set
-# CONFIG_TINY_RCU is not set
-CONFIG_X86_CMOV=y
-CONFIG_X86_DEBUGCTLMSR=y
-# CONFIG_X86_GENERIC is not set
-CONFIG_X86_INTERNODE_CACHE_SHIFT=5
-CONFIG_X86_L1_CACHE_SHIFT=5
-CONFIG_X86_TSC=y
-CONFIG_X86_USE_3DNOW=y
-CONFIG_X86_USE_PPRO_CHECKSUM=y
+# CONFIG_SERIO_SERPORT is not set
+CONFIG_THERMAL_HWMON=y
+# CONFIG_SENSORS_K10TEMP is not set
+# CONFIG_SENSORS_VIA_CPUTEMP is not set
index 07fdae643efcefaee37dd5e8b60a2cb373769c5e..7bac4fee5cf9a574e096ac6c62625857812b83df 100644 (file)
@@ -1,12 +1,29 @@
+LINUX_VERSION:=3.2.1
 BOARDNAME:=Soekris net5501
-FEATURES:=squashfs pci usb gpio
-DEFAULT_PACKAGES += kmod-ata-via-sata kmod-crypto-hw-geode \
-                       kmod-gpio-cs5535 kmod-gpio-nsc kmod-gpio-pc8736x \
-                       kmod-wdt-geode kmod-hwmon-core kmod-hwmon-pc87360 \
-                       kmod-via-rhine kmod-leds-net5501 \
+FEATURES:=squashfs jffs2 ext4 pci usb gpio
+DEFAULT_PACKAGES += kmod-crypto-hw-geode kmod-crypto-ocf \
+                       kmod-gpio-cs5535-new kmod-gpio-nsc \
+                       kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
+                       kmod-cs5536 \
+                       kmod-hwmon-core kmod-hwmon-pc87360 kmod-gpio-pc8736x \
+                       kmod-via-rhine kmod-solos-pci \
                        kmod-i2c-core kmod-i2c-gpio \
                        kmod-i2c-algo-bit kmod-i2c-algo-pca kmod-i2c-algo-pcf \
-                       kmod-usb-core kmod-usb2 kmod-usb-uhci
+                       kmod-i2c-scx200-acb \
+                       kmod-usb-core kmod-usb2 kmod-usb-ohci \
+                       kmod-cfg80211 kmod-mac80211 \
+                       kmod-mppe kmod-pppoe kmod-pppoa kmod-pppo2ltp \
+                       kmod-ath kmod-ath5k kmod-ath9k \
+                       kmod-leds-gpio kmod-input-gpio-keys-polled \
+                       kmod-button-hotplug \
+                       kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
+                       kmod-ledtrig-netdev kmod-ledtrig-netfilter \
+                       kmod-cpu-msr \
+                       soloscli linux-atm br2684ctl bridge ppp ppp-mod-pppoa \
+                       pppdump pppstats \
+                       libopenssl ocf-crypto-headers zlib hwclock hostapd
+
+CS5535_MASK:=0x01000040
 
 CFLAGS += -Os -pipe -march=k6-2 -fno-align-functions -fno-align-loops -fno-align-jumps \
          -fno-align-labels
@@ -15,3 +32,6 @@ define Target/Description
        Build firmware images for Soekris net5501 board
 endef
 
+define KernelPackage/gpio-cs5535-new/install
+       sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
+endef