ath79: add support for Qxwlan E750A v4
authorPeng Zhang <sd20@qxwlan.com>
Wed, 14 Oct 2020 07:47:35 +0000 (15:47 +0800)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Thu, 15 Oct 2020 16:52:39 +0000 (18:52 +0200)
Qxwlan E750A v4 is based on Qualcomm QCA9344.

Specification:

 - 560/450/225 MHz (CPU/DDR/AHB)
 - 128 MB of RAM (DDR2)
 - 8/16 MB of FLASH (SPI NOR)
 - 2T2R 5G GHz (AR9344)
 - 2x 10/100 Mbps Ethernet (one port with PoE support)
 - 1x miniPCIe slot (USB 2.0 bus only)
 - 7x LED (6 driven by GPIO)
 - 1x button (reset)
 - 1x DC jack for main power input (9-48 V)
 - UART (J23) and LEDs (J2) headers on PCB

Flash instruction:

   1.Using tftp mode with UART connection and original LEDE image
      - Configure PC with static IP 192.168.1.10 and tftp server.
      - Rename "openwrt-ar71xx-generic-xxx-squashfs-sysupgrade.bin"
        to "firmware.bin" and place it in tftp server directory.
      - Connect PC with one of LAN ports, power up the router and press
        key "Enter" to access U-Boot CLI.
      - Use the following commands to update the device to LEDE:
        run lfw
      - After that the device will reboot and boot to LEDE.
      - Wait until all LEDs stops flashing and use the router.

   2.Using httpd mode with Web UI connection and original LEDE image
      - Configure PC with static IP 192.168.1.xxx(2-255) and tftp server.
      - Connect PC with one of LAN ports,press the reset button, power up
        the router and keep button pressed for around 6-7 seconds, until
        leds flashing.
      - Open your browser and enter 192.168.1.1,You will see the upgrade
        interface, select "openwrt-ar71xx-generic-xxx-squashfs-
        sysupgrade.bin" and click the upgrade button.
      - After that the device will reboot and boot to LEDE.
      - Wait until all LEDs stops flashing and use the router.

Signed-off-by: Peng Zhang <sd20@qxwlan.com>
[cut out of bigger patch, alter use of DEVICE_VARIANT, merge case
in 01_leds, use lower case for v4]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ath79/dts/ar9344_qxwlan_e750a-v4-16m.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9344_qxwlan_e750a-v4-8m.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9344_qxwlan_e750x.dtsi [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/image/generic.mk

diff --git a/target/linux/ath79/dts/ar9344_qxwlan_e750a-v4-16m.dts b/target/linux/ath79/dts/ar9344_qxwlan_e750a-v4-16m.dts
new file mode 100644 (file)
index 0000000..61389be
--- /dev/null
@@ -0,0 +1,49 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344_qxwlan_e750x.dtsi"
+
+/ {
+       model = "Qxwlan E750A v4 16M";
+       compatible = "qxwlan,e750a-v4-16m", "qca,ar9344";
+};
+
+&leds {
+       lan {
+               label = "green:lan";
+               gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+       };
+
+       wan {
+               label = "green:wan";
+               gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&pridata 0x400>;
+       mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&pridata 0x400>;
+
+       gmac-config {
+               device = <&gmac>;
+               switch-phy-swap = <0>;
+               switch-only-mode = <1>;
+       };
+};
+
+&partitions {
+       partition@70000 {
+               compatible = "denx,uimage";
+               label = "firmware";
+               reg = <0x070000 0xf90000>;
+       };
+};
diff --git a/target/linux/ath79/dts/ar9344_qxwlan_e750a-v4-8m.dts b/target/linux/ath79/dts/ar9344_qxwlan_e750a-v4-8m.dts
new file mode 100644 (file)
index 0000000..e232cda
--- /dev/null
@@ -0,0 +1,49 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344_qxwlan_e750x.dtsi"
+
+/ {
+       model = "Qxwlan E750A v4 8M";
+       compatible = "qxwlan,e750a-v4-8m", "qca,ar9344";
+};
+
+&leds {
+       lan {
+               label = "green:lan";
+               gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+       };
+
+       wan {
+               label = "green:wan";
+               gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&pridata 0x400>;
+       mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+       status = "okay";
+
+       mtd-mac-address = <&pridata 0x400>;
+
+       gmac-config {
+               device = <&gmac>;
+               switch-phy-swap = <0>;
+               switch-only-mode = <1>;
+       };
+};
+
+&partitions {
+       partition@70000 {
+               compatible = "denx,uimage";
+               label = "firmware";
+               reg = <0x070000 0x790000>;
+       };
+};
diff --git a/target/linux/ath79/dts/ar9344_qxwlan_e750x.dtsi b/target/linux/ath79/dts/ar9344_qxwlan_e750x.dtsi
new file mode 100644 (file)
index 0000000..2cd7b44
--- /dev/null
@@ -0,0 +1,113 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       aliases {
+               label-mac-device = &eth0;
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       leds: leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "green:system";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               sig1 {
+                       label = "green:sig1";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               sig2 {
+                       label = "green:sig2";
+                       gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "green:wlan";
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                               read-only;
+                       };
+
+                       pridata: partition@50000 {
+                               label = "pri-data";
+                               reg = <0x050000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@60000 {
+                               label = "art";
+                               reg = <0x060000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&ref {
+       clock-frequency = <40000000>;
+};
+
+&uart {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+};
index cc5a9305319c9f1c5d1273da926c1a0833835715..0c130e329e229580b6ede74b3640a7dc6ddaac21 100755 (executable)
@@ -194,7 +194,9 @@ etactica,eg200)
        ucidef_set_led_netdev "lan" "LAN" "red:eth0" "eth0"
        ucidef_set_led_oneshot "modbus" "Modbus" "red:modbus" "100" "33"
        ;;
-glinet,gl-mifi)
+glinet,gl-mifi|\
+qxwlan,e750a-v4-8m|\
+qxwlan,e750a-v4-16m)
        ucidef_set_led_switch "lan" "LAN" "green:lan" "switch0" "0x02"
        ucidef_set_led_netdev "wan" "WAN" "green:wan" "eth1"
        ;;
index c0aacd7ff91d84b4644c7858e73e2882d22e38fc..f15d7a3b891a2cb9cb7ebb173ca643a9622c1a50 100644 (file)
@@ -1475,6 +1475,27 @@ define Device/qihoo_c301
 endef
 TARGET_DEVICES += qihoo_c301
 
+define Device/qxwlan_e750a-v4
+  SOC := ar9344
+  DEVICE_VENDOR := Qxwlan
+  DEVICE_MODEL := E750A
+  DEVICE_PACKAGES := kmod-usb2
+endef
+
+define Device/qxwlan_e750a-v4-16m
+  $(Device/qxwlan_e750a-v4)
+  DEVICE_VARIANT := v4 (16M)
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += qxwlan_e750a-v4-16m
+
+define Device/qxwlan_e750a-v4-8m
+  $(Device/qxwlan_e750a-v4)
+  DEVICE_VARIANT := v4 (8M)
+  IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += qxwlan_e750a-v4-8m
+
 define Device/rosinson_wr818
   SOC := qca9563
   DEVICE_VENDOR := Rosinson