curl: bump to 7.66.0
authorHans Dedecker <dedeckeh@gmail.com>
Tue, 17 Sep 2019 20:45:41 +0000 (22:45 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 7 Nov 2019 18:42:42 +0000 (19:42 +0100)
Refresh patches, for changes in version 7.66.0 see https://curl.haxx.se/changes.html#7_66_0

Fixes CVEs:
    CVE-2019-5481
    CVE-2019-5482

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
(cherry picked from commit 71cf4a272c9cf7d6e604e6327d0c94aeceac26e7)

package/network/utils/curl/Makefile
package/network/utils/curl/patches/200-no_docs_tests.patch

index 7f259a40350a0c60847610432c0f5b0695f74ec1..d4fcf1814aaffdf2aef67d9afc9ad276941dc17d 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.65.3
+PKG_VERSION:=7.66.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        https://curl.mirror.anstey.ca/ \
        https://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
        https://curl.mirror.anstey.ca/ \
        https://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
-PKG_HASH:=f2d98854813948d157f6a91236ae34ca4a1b4cb302617cebad263d79b0235fea
+PKG_HASH:=dbb48088193016d079b97c5c3efde8efa56ada2ebf336e8a97d04eb8e2ed98c1
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index 1aa86a7e499d485e2fe53ed817f6d1ece428466f..e52694e2c91d261143a456bd56dbd8425eaf8d99 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.am
 +++ b/Makefile.am
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -168,7 +168,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
+@@ -179,7 +179,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
  bin_SCRIPTS = curl-config
  
  SUBDIRS = lib src
@@ -9,7 +9,7 @@
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -279,8 +279,8 @@ cygwinbin:
+@@ -290,8 +290,8 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        cd include && $(MAKE) install
  # We extend the standard install with a custom hook:
  install-data-hook:
        cd include && $(MAKE) install