build, imagebuilder: Do not require libncurses-dev
authorPaul Spooren <mail@aparcar.org>
Tue, 14 Apr 2020 21:14:47 +0000 (11:14 -1000)
committerPaul Spooren <mail@aparcar.org>
Thu, 31 Dec 2020 19:31:54 +0000 (09:31 -1000)
The buildroot and SDK both require `libncurses-dev` to be installed on
the system, however the ImageBuilder uses precompiled binaries.

This patch changes the prerequirements checks to skip the
`libncurses-dev` part if running as ImageBuilder.

Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 4a1a58a3e2d2360950ff23a05f1f55b779174d6a)

include/prereq-build.mk

index 501739968cb689d61a8959808b1bb22b2d72b65b..622db96ee3abe9cac0c4652859eacbdb4182d0f1 100644 (file)
@@ -51,10 +51,12 @@ $(eval $(call TestHostCommand,working-g++, \
                g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
                $(TMP_DIR)/a.out))
 
+ifndef IB
 $(eval $(call TestHostCommand,ncurses, \
        Please install ncurses. (Missing libncurses.so or ncurses.h), \
        echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
                gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
+endif
 
 ifeq ($(HOST_OS),Linux)
   zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic