openssl: fix powerpc & arc libatomic dependencies
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Tue, 21 Feb 2023 20:55:26 +0000 (17:55 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Wed, 22 Feb 2023 14:05:06 +0000 (11:05 -0300)
PowerPC CONFIG_ARCH is defined as powerpc, not ppc.  Fix that in the
DEPENDS condition.

Arc needs to be built with libatomic.  Change the OpenSSL configuration
file, and add it to the libatomic DEPENDS condition.

Fixes: 7e7e76afca "openssl: bump to 3.0.8"
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
package/libs/openssl/Makefile
package/libs/openssl/patches/110-openwrt_targets.patch

index 7dc4df0982a79cd92a1a1c1c95f5e4f61e6d0ae0..153d14a4469cab06d1fddaf465dabec663f35c5b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_VERSION:=3.0.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_BUILD_PARALLEL:=1
@@ -95,7 +95,7 @@ $(call Package/openssl/Default)
           +OPENSSL_ENGINE_BUILTIN_AFALG:kmod-crypto-user \
           +OPENSSL_ENGINE_BUILTIN_DEVCRYPTO:kmod-cryptodev \
           +OPENSSL_ENGINE_BUILTIN_PADLOCK:kmod-crypto-hw-padlock \
-          +(arm||armeb||mips||mipsel||ppc):libatomic
+          +(arm||armeb||mips||mipsel||powerpc||arc):libatomic
   TITLE+= (libraries)
   ABI_VERSION:=$(firstword $(subst .,$(space),$(PKG_VERSION)))
   MENU:=1
index 6b4fbad0a78a9f6102f53c2bf8269ca4e2a9e82a..5abedd400e3b199ac448f7374cfd525d10636da7 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
 +        inherit_from    => [ "linux-aarch64", "openwrt" ],
 +    },
 +    "linux-arc-openwrt" => {
-+        inherit_from    => [ "linux-generic32", "openwrt" ],
++        inherit_from    => [ "linux-latomic", "openwrt" ],
 +    },
 +    "linux-arm-openwrt" => {
 +        inherit_from    => [ "linux-armv4", "openwrt" ],