ar71xx: add preliminary support for the Netgear WNDR3700
authorGabor Juhos <juhosg@openwrt.org>
Fri, 13 Nov 2009 17:11:29 +0000 (17:11 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 13 Nov 2009 17:11:29 +0000 (17:11 +0000)
Based on patches by Marco Porsch from:
https://forum.openwrt.org/viewtopic.php?id=22311

SVN-Revision: 18411

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/config-2.6.30
target/linux/ar71xx/config-2.6.31
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-wndr3700.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/profiles/netgear.mk [new file with mode: 0644]

index f8c46ac2bf49188a257411635e1b357fb5dde526..5ff2388715be875961700bb1a2b916a7324dd9af 100755 (executable)
@@ -67,6 +67,9 @@ ar71xx_board_name() {
        *WP543)
                name="wp543"
                ;;
        *WP543)
                name="wp543"
                ;;
+       *WNDR3700)
+               name"wndr3700"
+               ;;
        *WNR2000)
                name="wnr2000"
                ;;
        *WNR2000)
                name="wnr2000"
                ;;
index 137b10c749d1915a24e3d3d54961cd2a54ea8926..1a9ca7c776558a02ca3dbbce135143e0df363d0d 100644 (file)
@@ -17,6 +17,7 @@ CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
+CONFIG_AR71XX_MACH_WNDR3700=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WRT160NL=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WRT160NL=y
index 2c889526195ff37df7a5a5f8fb05f02634ffd75b..76c4829fd14dfe3b4d02b311f9bfbf631cf214cf 100644 (file)
@@ -16,6 +16,7 @@ CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
+CONFIG_AR71XX_MACH_WNDR3700=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WRT160NL=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WRT160NL=y
index 125ac99b0aff2f3705085db56ba78d92dd2f6f36..9d92bec78b16bdf6790bf5ba4fce67e2ca109aeb 100644 (file)
@@ -17,6 +17,7 @@ CONFIG_AR71XX_MACH_TEW_632BRP=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
 CONFIG_AR71XX_MACH_TL_WR741ND=y
 CONFIG_AR71XX_MACH_TL_WR941ND=y
 CONFIG_AR71XX_MACH_UBNT=y
+CONFIG_AR71XX_MACH_WNDR3700=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WRT160NL=y
 CONFIG_AR71XX_MACH_WNR2000=y
 CONFIG_AR71XX_MACH_WP543=y
 CONFIG_AR71XX_MACH_WRT160NL=y
index fe8553f84f5867d770ec76b1404db8dd19c6637a..72c28b460d8f36f6b550925e6fa9276f70d96ac5 100644 (file)
@@ -43,6 +43,10 @@ config AR71XX_MACH_RB_4XX
        bool "MikroTik RouterBOARD 4xx series support"
        default y
 
        bool "MikroTik RouterBOARD 4xx series support"
        default y
 
+config AR71XX_MACH_WNDR3700
+       bool "NETGEAR WNDR3700 board support"
+       default y
+
 config AR71XX_MACH_WNR2000
        bool "NETGEAR WNR2000 board support"
        default y
 config AR71XX_MACH_WNR2000
        bool "NETGEAR WNR2000 board support"
        default y
index ee439698ab2947675e2307b328b9dd17708d775e..71ba835dcfe3b48f41f8b827b6ec17d7ef2bf3c1 100644 (file)
@@ -26,6 +26,7 @@ obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)  += mach-tew-632brp.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR741ND)   += mach-tl-wr741nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR941ND)   += mach-tl-wr941nd.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR741ND)   += mach-tl-wr741nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WR941ND)   += mach-tl-wr941nd.o
 obj-$(CONFIG_AR71XX_MACH_UBNT)         += mach-ubnt.o
+obj-$(CONFIG_AR71XX_MACH_WNDR3700)     += mach-wndr3700.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
 obj-$(CONFIG_AR71XX_MACH_WRT160NL)     += mach-wrt160nl.o
 obj-$(CONFIG_AR71XX_MACH_WNR2000)      += mach-wnr2000.o
 obj-$(CONFIG_AR71XX_MACH_WP543)                += mach-wp543.o
 obj-$(CONFIG_AR71XX_MACH_WRT160NL)     += mach-wrt160nl.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-wndr3700.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-wndr3700.c
new file mode 100644 (file)
index 0000000..aee68cb
--- /dev/null
@@ -0,0 +1,131 @@
+/*
+ *  Netgear WNDR3700 board support
+ *
+ *  Copyright (C) 2009 Marco Porsch
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+
+#include "devices.h"
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition wndr3700_partitions[] = {
+       {
+               .name           = "uboot",
+               .offset         = 0,
+               .size           = 0x050000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "env",
+               .offset         = 0x050000,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "rootfs",
+               .offset         = 0x070000,
+               .size           = 0x720000,
+       } , {
+               .name           = "config",
+               .offset         = 0x790000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "config_bak",
+               .offset         = 0x7a0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "pot",
+               .offset         = 0x7b0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "traffic_meter",
+               .offset         = 0x7c0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "language",
+               .offset         = 0x7d0000,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "caldata",
+               .offset         = 0x7f0000,
+               .size           = 0x010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data wndr3700_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = wndr3700_partitions,
+        .nr_parts       = ARRAY_SIZE(wndr3700_partitions),
+#endif
+};
+
+static struct ar71xx_pci_irq wndr3700_pci_irqs[] __initdata = {
+       {
+               .slot   = 0,
+               .pin    = 1,
+               .irq    = AR71XX_PCI_IRQ_DEV0,
+       }, {
+               .slot   = 1,
+               .pin    = 1,
+               .irq    = AR71XX_PCI_IRQ_DEV1,
+       }
+};
+
+static struct spi_board_info wndr3700_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+               .platform_data  = &wndr3700_flash_data,
+       }
+};
+
+static void __init wndr3700_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       ar71xx_set_mac_base(mac);
+       ar71xx_add_device_mdio(0x0);
+
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth0_data.phy_mask = 0xf;
+       ar71xx_eth0_data.speed = SPEED_1000;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ar71xx_eth1_data.phy_mask = 0x10;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       ar71xx_add_device_usb();
+
+       ar71xx_pci_init(ARRAY_SIZE(wndr3700_pci_irqs), wndr3700_pci_irqs);
+
+       ar71xx_add_device_spi(NULL, wndr3700_spi_info,
+                             ARRAY_SIZE(wndr3700_spi_info));
+
+       /* TODO: LEDs, buttons support */
+}
+
+MIPS_MACHINE(AR71XX_MACH_WNDR3700, "NETGEAR WNDR3700", wndr3700_setup);
index ed6f4e99323262529f5c5556182fca6813c35b24..43d663243e4556d13529a509a550f42d747e0c31 100644 (file)
@@ -85,6 +85,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "UBNT-BM",
                .mach_type      = AR71XX_MACH_UBNT_BULLET_M,
        }, {
                .name           = "UBNT-BM",
                .mach_type      = AR71XX_MACH_UBNT_BULLET_M,
+       }, {
+               .name           = "WNDR3700",
+               .mach_type      = AR71XX_MACH_WNDR3700,
        }, {
                .name           = "WNR2000",
                .mach_type      = AR71XX_MACH_WNR2000,
        }, {
                .name           = "WNR2000",
                .mach_type      = AR71XX_MACH_WNR2000,
index 4d2f7f2164214ba4f8f3ce0ef9338171f12db6e6..2388acaba7914ce6ec8f57819c47492a30e8422c 100644 (file)
@@ -142,6 +142,7 @@ enum ar71xx_mach_type {
        AR71XX_MACH_UBNT_RSPRO, /* Ubiquiti RouterStation Pro */
        AR71XX_MACH_UBNT_BULLET_M, /* Ubiquiti Bullet M */
        AR71XX_MACH_WNR2000,    /* NETGEAR WNR2000 */
        AR71XX_MACH_UBNT_RSPRO, /* Ubiquiti RouterStation Pro */
        AR71XX_MACH_UBNT_BULLET_M, /* Ubiquiti Bullet M */
        AR71XX_MACH_WNR2000,    /* NETGEAR WNR2000 */
+       AR71XX_MACH_WNDR3700,   /* NETGEAR WNDR3700 */
        AR71XX_MACH_WP543,      /* Compex WP543 */
        AR71XX_MACH_WRT160NL,   /* Linksys WRT160NL */
        AR71XX_MACH_WRT400N,    /* Linksys WRT400N */
        AR71XX_MACH_WP543,      /* Compex WP543 */
        AR71XX_MACH_WRT160NL,   /* Linksys WRT160NL */
        AR71XX_MACH_WRT400N,    /* Linksys WRT400N */
diff --git a/target/linux/ar71xx/profiles/netgear.mk b/target/linux/ar71xx/profiles/netgear.mk
new file mode 100644 (file)
index 0000000..89deaaa
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WNDR3700
+       NAME:=NETGEAR WNDR3700
+       PACKAGES:=kmod-ath9k hostapd-mini kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/WNDR3700/Description
+       Package set optimized for the NETGEAR WNDR3700
+endef
+
+$(eval $(call Profile,WNDR3700))