base-files: use a natural mount syntax
authorFlorian Fainelli <florian@openwrt.org>
Fri, 23 Nov 2012 20:02:02 +0000 (20:02 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 23 Nov 2012 20:02:02 +0000 (20:02 +0000)
Busybox built against musl-libc will choke on these otherwise, besides that
it is more natural to use the filesystem type, then options, then name, then
mountpoint.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34308

package/base-files/Makefile
package/base-files/files/lib/preinit/10_essential_fs
package/base-files/files/lib/preinit/10_indicate_preinit
package/base-files/files/lib/preinit/20_device_fs_mount
package/base-files/files/lib/preinit/40_mount_devpts
package/base-files/files/lib/preinit/80_mount_root

index 27ce05164a52909ed5338b04ef2a310dc5d65211..972f96b0cbf5a385e7949c1c5b0cfb4b4e8e6f73 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=118
+PKG_RELEASE:=119
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index ab317dc20aeb3b0f98cb3c2c989b4ada0bcff3cc..5d979fd49a6461d90834e265da1b415f15eac134 100644 (file)
@@ -3,11 +3,11 @@
 # Copyright (C) 2010 Vertical Communications
 
 do_mount_procfs() {
-   mount proc /proc -t proc
+   mount -t proc proc /proc
 }
 
 do_mount_sysfs() {
-    mount sysfs /sys -t sysfs
+   mount -t sysfs sysfs /sys
 }
 
 calc_tmpfs_size() {
@@ -16,7 +16,7 @@ calc_tmpfs_size() {
 
 do_mount_tmpfs() {
     calc_tmpfs_size
-    mount tmpfs /tmp -t tmpfs -o size=$pi_size,nosuid,nodev,mode=1777
+    mount -t tmpfs -o size=$pi_size,nosuid,nodev,mode=1777 tmpfs /tmp
 }
 
 boot_hook_add preinit_essential do_mount_procfs
index ab693051808e54da45ad039d3731c110c9d38e04..4a0109cc1736daf550f5ff17ea59c2e17a61841e 100644 (file)
@@ -27,7 +27,6 @@ preinit_net_echo() {
                                [ "$pi_failsafe_net_message"  = "true" ] && 
                                    [ "$pi_preinit_no_failsafe_netmsg" != "y" ] 
                         }
-                               
                } && netmsg $pi_broadcast "$1"
        }
 }
index 832b1cf399791a0d09feba8ec134a38ed6d2d3fe..ed59b5b237f693eea9a51f2be78ee7dde7f022f7 100644 (file)
@@ -10,11 +10,11 @@ do_move_devtmpfs() {
 }
 
 do_mount_devfs() {
-    mount devfs /dev -t devfs
+    mount -t devfs devfs /dev
 }
 
 do_mount_hotplug() {
-    mount -t tmpfs tmpfs /dev -o mode=0755,size=512K
+    mount -t tmpfs -o mode=0755,size=512K tmpfs /dev
 }
 
 do_mount_udev() {
index 2d5010b9122dc86f4b179003c4173552e4297ac2..b75d692878bce382aa4a34fe797cdfb83031dafd 100644 (file)
@@ -7,7 +7,7 @@ init_devpts() {
 }
 
 do_mount_devpts() {
-    mount devpts /dev/pts -t devpts
+    mount -t devpts devpts /dev/pts
 }
 
 boot_hook_add preinit_essential init_devpts
index cc8781687e1ba47a2e85424b9952fb7bc1389978..ad24fb8ace70707e434c9980d948399834ce160f 100644 (file)
@@ -4,7 +4,7 @@
 
 do_mount_root() {
     boot_run_hook preinit_mount_root
-}   
+}
 
 boot_hook_add preinit_main do_mount_root