kernel: drop crypto-hw-ppc4xx
authorFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 11:55:27 +0000 (12:55 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 10 Jan 2017 12:44:25 +0000 (13:44 +0100)
If any of the ppc4xx targets are restored, this should be built into the
kernel instead

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/linux/modules/crypto.mk

index 0f8305285de0439a3ba7e12e06ddac5be982e2d0..abbd5afd663f1d2ecbbdf9259db8e96cb82129f2 100644 (file)
@@ -240,24 +240,6 @@ endef
 $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
 
-define KernelPackage/crypto-hw-ppc4xx
-  TITLE:=AMCC PPC4xx hardware crypto module
-  DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
-  KCONFIG:= \
-       CONFIG_CRYPTO_HW=y \
-       CONFIG_CRYPTO_DEV_PPC4XX
-  FILES:=$(LINUX_DIR)/drivers/crypto/amcc/crypto4xx.ko
-  AUTOLOAD:=$(call AutoLoad,90,crypto4xx)
-  $(call AddDepends/crypto,+kmod-crypto-manager +kmod-crypto-hash)
-endef
-
-define KernelPackage/crypto-hw-ppc4xx/description
-  Kernel support for the AMCC PPC4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-hw-ppc4xx))
-
-
 define KernelPackage/crypto-hw-omap
   TITLE:=TI OMAP hardware crypto modules
   DEPENDS:=@TARGET_omap