kernel: add mvsw61xx module package
authorJohn Crispin <john@openwrt.org>
Mon, 19 Oct 2015 10:10:41 +0000 (10:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 19 Oct 2015 10:10:41 +0000 (10:10 +0000)
Adds the package to select the mvsw61xx module present in the 3.18/4.0/4.1
kernels.

Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com>
SVN-Revision: 47224

package/kernel/linux/modules/netdevices.mk

index 9efac98a4218afa6c4315e91d355e33f884440f5..ef3cf85ef87097f78fe438a46f5d27a2ac816d4a 100644 (file)
@@ -180,6 +180,20 @@ endef
 
 $(eval $(call KernelPackage,swconfig))
 
 
 $(eval $(call KernelPackage,swconfig))
 
+define KernelPackage/switch-mvsw61xx
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=Marvell 88E61xx switch support
+  DEPENDS:=+kmod-swconfig
+  KCONFIG:=CONFIG_MVSW61XX_PHY
+  FILES:=$(LINUX_DIR)/drivers/net/phy/mvsw61xx.ko
+  AUTOLOAD:=$(call AutoLoad,42,mvsw61xx)
+endef
+
+define KernelPackage/switch-mvsw61xx/description
+ Marvell 88E61xx switch support
+endef
+
+$(eval $(call KernelPackage,switch-mvsw61xx))
 
 define KernelPackage/switch-ip17xx
   SUBMENU:=$(NETWORK_DEVICES_MENU)
 
 define KernelPackage/switch-ip17xx
   SUBMENU:=$(NETWORK_DEVICES_MENU)