mediatek: new target ubnt_unifi-6-lr-v1-ubootmod
authorHenrik Riomar <henrik.riomar@gmail.com>
Tue, 31 May 2022 17:49:49 +0000 (19:49 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 11 Jun 2022 18:51:18 +0000 (19:51 +0100)
based on current ubnt_unifi-6-lr-ubootmod

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
[added SUPPORTED_DEVICES for compatibility with existing setups]
Signed-off-by: Henrik Riomar <henrik.riomar@gmail.com>
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-ubootmod.dts [deleted file]
target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1-ubootmod.dts [new file with mode: 0644]
target/linux/mediatek/image/mt7622.mk

diff --git a/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-ubootmod.dts b/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-ubootmod.dts
deleted file mode 100644 (file)
index 8a9d0a1..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-
-#include "mt7622-ubnt-unifi-6-lr-v1.dtsi"
-
-/ {
-       model = "Ubiquiti UniFi 6 LR (U-Boot mod)";
-       compatible = "ubnt,unifi-6-lr-ubootmod", "mediatek,mt7622";
-};
-
-&nor_partitions {
-       partition@0 {
-               label = "bl2";
-               reg = <0x0 0x20000>;
-       };
-
-       partition@20000 {
-               label = "fip";
-               reg = <0x20000 0xa0000>;
-       };
-
-       partition@c0000 {
-               label = "u-boot-env";
-               reg = <0xc0000 0x10000>;
-       };
-
-       factory: partition@d0000 {
-               label = "factory";
-               reg = <0xd0000 0x40000>;
-               read-only;
-       };
-
-       eeprom: partition@110000 {
-               label = "eeprom";
-               reg = <0x110000 0x10000>;
-               read-only;
-       };
-
-       partition@120000 {
-               label = "recovery";
-               reg = <0x120000 0xee0000>;
-       };
-
-       partition@1000000 {
-               compatible = "denx,fit";
-               label = "firmware";
-               reg = <0x1000000 0x3000000>;
-       };
-};
-
-&wmac {
-       mediatek,mtd-eeprom = <&factory 0x0>;
-       nvmem-cells = <&macaddr_eeprom_0>;
-       nvmem-cell-names = "mac-address";
-       status = "okay";
-};
-
-&slot0 {
-       wifi@0,0 {
-               reg = <0x0 0 0 0 0>;
-               mediatek,mtd-eeprom = <&factory 0x20000>;
-               nvmem-cells = <&macaddr_eeprom_6>;
-               nvmem-cell-names = "mac-address";
-               ieee80211-freq-limit = <5000000 6000000>;
-       };
-};
-
-&gmac0 {
-       nvmem-cells = <&macaddr_eeprom_0>;
-       nvmem-cell-names = "mac-address";
-};
-
-&eeprom {
-       compatible = "nvmem-cells";
-       #address-cells = <1>;
-       #size-cells = <1>;
-
-       macaddr_eeprom_0: macaddr@0 {
-               reg = <0x0 0x6>;
-       };
-
-       macaddr_eeprom_6: macaddr@6 {
-               reg = <0x6 0x6>;
-       };
-};
diff --git a/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1-ubootmod.dts b/target/linux/mediatek/dts/mt7622-ubnt-unifi-6-lr-v1-ubootmod.dts
new file mode 100644 (file)
index 0000000..a22bc70
--- /dev/null
@@ -0,0 +1,84 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7622-ubnt-unifi-6-lr-v1.dtsi"
+
+/ {
+       model = "Ubiquiti UniFi 6 LR v1 (U-Boot mod)";
+       compatible = "ubnt,unifi-6-lr-ubootmod", "mediatek,mt7622";
+};
+
+&nor_partitions {
+       partition@0 {
+               label = "bl2";
+               reg = <0x0 0x20000>;
+       };
+
+       partition@20000 {
+               label = "fip";
+               reg = <0x20000 0xa0000>;
+       };
+
+       partition@c0000 {
+               label = "u-boot-env";
+               reg = <0xc0000 0x10000>;
+       };
+
+       factory: partition@d0000 {
+               label = "factory";
+               reg = <0xd0000 0x40000>;
+               read-only;
+       };
+
+       eeprom: partition@110000 {
+               label = "eeprom";
+               reg = <0x110000 0x10000>;
+               read-only;
+       };
+
+       partition@120000 {
+               label = "recovery";
+               reg = <0x120000 0xee0000>;
+       };
+
+       partition@1000000 {
+               compatible = "denx,fit";
+               label = "firmware";
+               reg = <0x1000000 0x3000000>;
+       };
+};
+
+&wmac {
+       mediatek,mtd-eeprom = <&factory 0x0>;
+       nvmem-cells = <&macaddr_eeprom_0>;
+       nvmem-cell-names = "mac-address";
+       status = "okay";
+};
+
+&slot0 {
+       wifi@0,0 {
+               reg = <0x0 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x20000>;
+               nvmem-cells = <&macaddr_eeprom_6>;
+               nvmem-cell-names = "mac-address";
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&gmac0 {
+       nvmem-cells = <&macaddr_eeprom_0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&eeprom {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_eeprom_0: macaddr@0 {
+               reg = <0x0 0x6>;
+       };
+
+       macaddr_eeprom_6: macaddr@6 {
+               reg = <0x6 0x6>;
+       };
+};
index d6308f2ef63f0f533e2adc66adf93bcec7e772f2..b456af46a0faee24b62b66b15c2c065233f540bc 100644 (file)
@@ -254,11 +254,11 @@ define Device/ubnt_unifi-6-lr-v1
 endef
 TARGET_DEVICES += ubnt_unifi-6-lr-v1
 
-define Device/ubnt_unifi-6-lr-ubootmod
+define Device/ubnt_unifi-6-lr-v1-ubootmod
   DEVICE_VENDOR := Ubiquiti
   DEVICE_MODEL := UniFi 6 LR
-  DEVICE_VARIANT := U-Boot mod
-  DEVICE_DTS := mt7622-ubnt-unifi-6-lr-ubootmod
+  DEVICE_VARIANT := v1 U-Boot mod
+  DEVICE_DTS := mt7622-ubnt-unifi-6-lr-v1-ubootmod
   DEVICE_DTS_DIR := ../dts
   DEVICE_PACKAGES := kmod-mt7915e kmod-leds-ubnt-ledbar
   KERNEL := kernel-bin | lzma
@@ -269,8 +269,9 @@ define Device/ubnt_unifi-6-lr-ubootmod
   ARTIFACTS := preloader.bin bl31-uboot.fip
   ARTIFACT/preloader.bin := bl2 nor-2ddr
   ARTIFACT/bl31-uboot.fip := bl31-uboot ubnt_unifi-6-lr
+  SUPPORTED_DEVICES += ubnt,unifi-6-lr-ubootmod
 endef
-TARGET_DEVICES += ubnt_unifi-6-lr-ubootmod
+TARGET_DEVICES += ubnt_unifi-6-lr-v1-ubootmod
 
 define Device/xiaomi_redmi-router-ax6s
   DEVICE_VENDOR := Xiaomi