add monit
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 20 Apr 2005 22:05:02 +0000 (22:05 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Wed, 20 Apr 2005 22:05:02 +0000 (22:05 +0000)
SVN-Revision: 694

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/monit/Config.in [new file with mode: 0644]
openwrt/package/monit/Makefile [new file with mode: 0644]
openwrt/package/monit/monit.control [new file with mode: 0644]

index d6fa8b53c7076674ba11a2b4b2467465cef6d83a..d9a9cd804d7650e14a9cdc6a1501b4e91beb5747 100644 (file)
@@ -11,6 +11,7 @@ source "package/bridge/Config.in"
 comment "Applications"
 source "package/haserl/Config.in"
 source "package/microperl/Config.in"
+source "package/monit/Config.in"
 source "package/strace/Config.in"
 source "package/lcd4linux/Config.in"
 source "package/setserial/Config.in"
index 41681ce02bf3f7f10e9e15062ba7529861a38e13..70761f537f4ace6365116c2a7c2189007062e8ee 100644 (file)
@@ -32,6 +32,7 @@ package-$(BR2_PACKAGE_LIBUSB) += libusb
 package-$(BR2_PACKAGE_LZO) += lzo
 package-$(BR2_PACKAGE_MATRIXSSL) += matrixssl
 package-$(BR2_PACKAGE_MICROPERL) += microperl
+package-$(BR2_PACKAGE_MONIT) += monit
 package-$(BR2_PACKAGE_NCURSES) += ncurses
 package-$(BR2_PACKAGE_NFSD) += nfs-server
 package-$(BR2_PACKAGE_NOCATSPLASH) += nocatsplash
diff --git a/openwrt/package/monit/Config.in b/openwrt/package/monit/Config.in
new file mode 100644 (file)
index 0000000..1458b8d
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_MONIT
+       tristate "monit"
+       select BR2_PACKAGE_LIBPTHREAD
+       default m if CONFIG_DEVEL
+       help
+         utility for monitoring services on a Unix system
+         
+         http://www.tildeslash.com/monit/
diff --git a/openwrt/package/monit/Makefile b/openwrt/package/monit/Makefile
new file mode 100644 (file)
index 0000000..393d449
--- /dev/null
@@ -0,0 +1,67 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=monit
+PKG_VERSION:=4.5.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=0f054ac39822b4be71789d49e4813754
+
+PKG_SOURCE_URL:=http://www.tildeslash.com/monit/dist/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               --without-ssl \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/monit: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/monit
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin
+       cp $(PKG_BUILD_DIR)/monit $(PKG_IPK_DIR)/usr/sbin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/monit.list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/monit.list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/monit/monit.control b/openwrt/package/monit/monit.control
new file mode 100644 (file)
index 0000000..87892ad
--- /dev/null
@@ -0,0 +1,7 @@
+Package: monit
+Priority: optional
+Section: net
+Maintainer: Waldemar Brodkorb <wbx@dass-it.de>
+Depends: libpthread
+Source: buildroot internal
+Description: utility for monitoring services on a Unix system