ramips: fix Mercury MAC1200R v2.0 board name
authorMathias Kresin <dev@kresin.me>
Fri, 28 Jul 2017 17:22:55 +0000 (19:22 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 29 Jul 2017 07:24:59 +0000 (09:24 +0200)
With d2b6bf141662 ("ramips: fix image validation errors") the board
name was changed to fix an image validation error. But this change
wasn't applied to all other files using the board name, which broke
sysupgrade.

Revert this change and use the former board name in the metadata
instead.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/image/mt7628.mk

index e642d568c46f4ae547a6d3c7ba6ff032bb22fc8a..17ada648931f16d3e85630dd341defb89ba50d6f 100755 (executable)
@@ -272,7 +272,7 @@ ramips_board_detect() {
                name="m2m"
                ;;
        *"Mercury MAC1200R v2")
                name="m2m"
                ;;
        *"Mercury MAC1200R v2")
-               name="mac1200r-v2"
+               name="mac1200rv2"
                ;;
        *"MicroWRT")
                name="microwrt"
                ;;
        *"MicroWRT")
                name="microwrt"
index 4502588c80ee90b22cadd3f21c6f044b9a368090..12c3c8050797adfb3bc96441d379529f7816c5d3 100644 (file)
@@ -53,5 +53,6 @@ TARGET_DEVICES += duzun-dm06
 define Device/mac1200r-v2
   DTS := MAC1200RV2
   DEVICE_TITLE := Mercury MAC1200R v2.0
 define Device/mac1200r-v2
   DTS := MAC1200RV2
   DEVICE_TITLE := Mercury MAC1200R v2.0
+  SUPPORTED_DEVICES := mac1200rv2
 endef
 TARGET_DEVICES += mac1200r-v2
 endef
 TARGET_DEVICES += mac1200r-v2