bcm4908: enable target & Asus GT-AC5300 image
authorRafał Miłecki <rafal@milecki.pl>
Thu, 8 Apr 2021 07:12:43 +0000 (09:12 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 8 Apr 2021 08:50:59 +0000 (10:50 +0200)
OpenWrt was succesfully tested on the GT-AC5300 model. It's possible to:
1. Install OpenWrt using vendor UI
2. Perform UBI aware sysupgrade
3. Install vendor firmware using OpenWrt sysupgrade

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
target/linux/bcm4908/Makefile
target/linux/bcm4908/image/Makefile

index 4edd0ccfa853f2ebc08958a61d130ae276030cee..ce5f230ca6746defc78cf06c25e096331a46248f 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=aarch64
 BOARD:=bcm4908
 BOARDNAME:=Broadcom BCM4908 (ARMv8A CPUs Brahma-B53)
-FEATURES:=squashfs nand usb pci pcie gpio source-only
+FEATURES:=squashfs nand usb pci pcie gpio
 CPU_TYPE:=cortex-a53
 SUBTARGETS:=generic
 
index bc0ee09c19e23a83089da92007ee9486e2766ac4..8a2d4dc17410b481ffa6bedb9e855f1aeda8d465 100644 (file)
@@ -71,6 +71,7 @@ define Device/netgear_r8000p
   IMAGE/chk := append-ubi | bcm4908img | netgear-chk
   NETGEAR_BOARD_ID := U12H359T00_NETGEAR
   NETGEAR_REGION := 1
+  BROKEN := y
 endef
 TARGET_DEVICES += netgear_r8000p
 
@@ -81,6 +82,7 @@ define Device/tplink_archer-c2300-v1
   DEVICE_DTS := broadcom/bcm4908/bcm4906-tplink-archer-c2300-v1
   IMAGES := bin
   IMAGE/bin := append-ubi | bcm4908img
+  BROKEN := y
 endef
 TARGET_DEVICES += tplink_archer-c2300-v1