kernel: bump 4.14 to 4.14.110
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 5 Apr 2019 08:58:45 +0000 (10:58 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 10:07:28 +0000 (12:07 +0200)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/mpc85xx/patches-4.14/102-powerpc-add-cmdline-override.patch

index 18f5321b7d3cdc2243fe5e5a5f13d919d661c25e..328aced1bf5ee287077a7944d4ae55397314e6b0 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .136
 LINUX_VERSION-4.9 = .167
-LINUX_VERSION-4.14 = .109
+LINUX_VERSION-4.14 = .110
 LINUX_VERSION-4.19 = .25
 
 LINUX_KERNEL_HASH-3.18.136 = 48c8775013d23229462134f911bbb14c7935096fcccfb19ce28ecd5f7154f35c
 LINUX_KERNEL_HASH-4.9.167 = a2b8608a2fe7a6203ed46c3a3d55091b19ac8304dded6338410a361dc63f0a8c
-LINUX_KERNEL_HASH-4.14.109 = 3764f165f779568745f1468d8f7e1db65d94eae9cd8d1350f4fe003a0fd88ee0
+LINUX_KERNEL_HASH-4.14.110 = 99ea359464dc8a7ab9862195934a1f3504c38a32af5fa424e3ae56244dd59e72
 LINUX_KERNEL_HASH-4.19.25 = 7ec71d90d6e96e6f741676d157ac06f30c75be4eaf1649143a3c8b7d4f919731
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 9f07fddc65f07796ccd63aa7649229fab5d41790..7053f61a0c269276a6ca735cb1def01382245f10 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1936,7 +1936,8 @@ static const struct usb_device_id option
+@@ -1941,7 +1941,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 35fa2545eb3648efde3470a8b09c2be8377c9e58..b5cbb4096f9fb32d93cc0cee090542ac65550751 100644 (file)
@@ -1202,7 +1202,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                xhci->quirks |= XHCI_BROKEN_PORT_PED;
 --- a/drivers/usb/host/xhci-ring.c
 +++ b/drivers/usb/host/xhci-ring.c
-@@ -1969,10 +1969,12 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1972,10 +1972,12 @@ static int finish_td(struct xhci_hcd *xh
        union xhci_trb *ep_trb, struct xhci_transfer_event *event,
        struct xhci_virt_ep *ep, int *status)
  {
@@ -1215,7 +1215,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        u32 trb_comp_code;
        int ep_index;
  
-@@ -1995,14 +1997,30 @@ static int finish_td(struct xhci_hcd *xh
+@@ -1998,14 +2000,30 @@ static int finish_td(struct xhci_hcd *xh
        if (trb_comp_code == COMP_STALL_ERROR ||
                xhci_requires_manual_halt_cleanup(xhci, ep_ctx,
                                                trb_comp_code)) {
index a3b69bbbb344ff03a9c0e5efb000caffef1e90e1..6a16a34a187c853666c3fd00c5e052aa35bc2d25 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/powerpc/Kconfig
 +++ b/arch/powerpc/Kconfig
-@@ -830,6 +830,14 @@ config CMDLINE_FORCE
+@@ -835,6 +835,14 @@ config CMDLINE_FORCE
          This is useful if you cannot or don't want to change the
          command-line options your boot loader passes to the kernel.