refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Wed, 3 Jun 2009 18:32:32 +0000 (18:32 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 3 Jun 2009 18:32:32 +0000 (18:32 +0000)
SVN-Revision: 16312

target/linux/ar71xx/patches-2.6.29/104-mtd_m25p80_add_redboot_parser.patch
target/linux/ar71xx/patches-2.6.29/105-mtd_m25p80_add_mx25lxxx_support.patch
target/linux/ar71xx/patches-2.6.29/106-mtd_m25p80_add_xxxs33b_support.patch
target/linux/ar71xx/patches-2.6.30/001-ar71xx_core.patch
target/linux/ar71xx/patches-2.6.30/101-ksz8041_phy_driver.patch
target/linux/ar71xx/patches-2.6.30/300-mips_fw_myloader.patch

index 462ae68791ef85989b7bdc1a70665ea289082c16..6464a3e9b7a3b3032b3fc863c7857279619ba3ee 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -722,6 +722,9 @@ static int __devinit m25p_probe(struct s
+@@ -723,6 +723,9 @@ static int __devinit m25p_probe(struct s
  #ifdef CONFIG_MTD_MYLOADER_PARTS
                                                "MyLoader",
  #endif
index 9456ac4314e8371f92eb04dc19905b8d910387ef..ab2a18ff2e1c6fc9539286eb62ff555a6c4e468c 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -507,6 +507,11 @@ static struct flash_info __devinitdata m
-       /* EON -- en25px */
-       { "en25p32", 0x1c2016, 0, 64 * 1024, 64, },
+@@ -508,6 +508,11 @@ static struct flash_info __devinitdata m
+       { "en25p32", 0x1c2016, 0, 64 * 1024,  64, },
+       { "en25p64", 0x1c2017, 0, 64 * 1024, 128, },
  
 +      /* Macronix -- mx25lxxx */
 +      { "mx25l32",  0xc22016, 0, 64 * 1024,  64, },
index e4e01637d66bddff7ad64dd615e5937a006842ed..40e5c407fd82f5189f7213f5f35389b054d29f7b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/devices/m25p80.c
 +++ b/drivers/mtd/devices/m25p80.c
-@@ -512,6 +512,11 @@ static struct flash_info __devinitdata m
+@@ -513,6 +513,11 @@ static struct flash_info __devinitdata m
        { "mx25l64",  0xc22017, 0, 64 * 1024, 128, },
        { "mx25l128", 0xc22018, 0, 64 * 1024, 256, },
  
index 0a2d2e7936609d73c5a0f258b950bb579e867861..40fcd51894c3a3dbadd270106af3c3b4c9326ebc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -603,6 +603,13 @@ else
+@@ -610,6 +610,13 @@ else
  load-$(CONFIG_CPU_CAVIUM_OCTEON)      += 0xffffffff81100000
  endif
  
index 0de88532b8374179ca71e3e603599a40e9d9abf5..828a3f9b9aad732d73d95c70f67b2d789a3712f8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -100,6 +100,11 @@ config AR8216_PHY
+@@ -104,6 +104,11 @@ config AR8216_PHY
        tristate "Driver for Atheros AR8216 switches"
        select SWCONFIG
  
@@ -14,7 +14,7 @@
        depends on PHYLIB=y
 --- a/drivers/net/phy/Makefile
 +++ b/drivers/net/phy/Makefile
-@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY)   += mvswitch.o
+@@ -19,6 +19,7 @@ obj-$(CONFIG_IP175C_PHY)     += ip175c.o
  obj-$(CONFIG_REALTEK_PHY)     += realtek.o
  obj-$(CONFIG_AR8216_PHY)      += ar8216.o
  obj-$(CONFIG_LSI_ET1011C_PHY) += et1011c.o
index 31de67686fd9f360db6c872ba68ef34939c86053..cbe4d68251542c0975c2a9e8621de8643340eb1b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Makefile
 +++ b/arch/mips/Makefile
-@@ -165,6 +165,7 @@ endif
+@@ -172,6 +172,7 @@ endif
  #
  libs-$(CONFIG_ARC)            += arch/mips/fw/arc/
  libs-$(CONFIG_CFE)            += arch/mips/fw/cfe/