ath79: Add support for TP-Link CPE210 v3
authorMario Schroen <m.schroen@web.de>
Sun, 31 Mar 2019 19:07:03 +0000 (21:07 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 2 Apr 2019 00:10:59 +0000 (02:10 +0200)
Specifications:

    * SoC: Qualcomm Atheros QCA9533 (650MHz)
    * RAM: 64MB
    * Storage: 8 MB SPI NOR
    * Wireless: 2.4GHz N based built into SoC 2x2
    * Ethernet: 1x 100/10 Mbps, integrated into SoC, 24V POE IN

Installation:
    Flash factory image through stock firmware WEB UI or TFTP
    To get to TFTP recovery just hold reset button while powering
    on for around 4-5 seconds and release.
    Rename factory image to recovery.bin
    Stock TFTP server IP:192.168.0.100
    Stock device TFTP adress:192.168.0.254

Thanks to robimarko for the work inside the ar71xx tree.
Thanks to adrianschmutzler for deep discussion and fixes.

Signed-off-by: Mario Schroen <m.schroen@web.de>
[Split into DTS/DTSI, read-only config partition in DTSI]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
[renamed dtsi filename, light subject touches]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 68cff4b4b04707a9bd69500525d0106e5d425dcd..47fac182814b76c8bc10e561a6975e9fc0478f8d 100755 (executable)
@@ -123,6 +123,14 @@ tplink,archer-c6-v2)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x3C"
        ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x02"
        ;;
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x3C"
        ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x02"
        ;;
+tplink,cpe210-v3)
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+       ucidef_set_rssimon "wlan0" "200000" "1"
+       ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:link1" "wlan0" "1" "100"
+       ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:link2" "wlan0" "30" "100"
+       ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:link3" "wlan0" "60" "100"
+       ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "tp-link:green:link4" "wlan0" "80" "100"
+       ;;
 tplink,re450-v2)
        ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
        ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
 tplink,re450-v2)
        ucidef_set_led_netdev "lan_data" "LAN Data" "tp-link:green:lan_data" "eth0" "tx rx"
        ucidef_set_led_netdev "lan_link" "LAN Link" "tp-link:green:lan_link" "eth0" "link"
index a328ef36e95a71beed9617feb950862e6a9dd2f2..1041af561e5b2ca72ed63dad7044e74a2fdce410 100755 (executable)
@@ -19,6 +19,7 @@ ath79_setup_interfaces()
        pcs,cap324|\
        pisen,wmm003n|\
        pqi,air-pen|\
        pcs,cap324|\
        pisen,wmm003n|\
        pqi,air-pen|\
+       tplink,cpe210-v3|\
        tplink,re350k-v1|\
        tplink,re450-v2|\
        tplink,tl-mr10u|\
        tplink,re350k-v1|\
        tplink,re450-v2|\
        tplink,tl-mr10u|\
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts b/target/linux/ath79/dts/qca9533_tplink_cpe210-v3.dts
new file mode 100644 (file)
index 0000000..cf1f728
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_cpe210.dtsi"
+
+/ {
+       compatible = "tplink,cpe210-v3", "qca,qca9533";
+       model = "TP-LINK CPE210 v3";
+};
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi b/target/linux/ath79/dts/qca9533_tplink_cpe210.dtsi
new file mode 100644 (file)
index 0000000..ee1f904
--- /dev/null
@@ -0,0 +1,125 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca953x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-boot = &system;
+               led-failsafe = &system;
+               led-running = &system;
+               led-upgrade = &system;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               link1 {
+                       label = "tp-link:green:link1";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               link2 {
+                       label = "tp-link:green:link2";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               link3 {
+                       label = "tp-link:green:link3";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               system: link4 {
+                       label = "tp-link:green:link4";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "partition-table";
+                               reg = <0x020000 0x10000>;
+                               read-only;
+                       };
+
+                       info: partition@30000 {
+                               label = "product-info";
+                               reg = <0x030000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "firmware";
+                               reg = <0x040000 0x780000>;
+                               compatible = "tplink,firmware";
+                       };
+
+                       config: partition@7c0000 {
+                               label = "config";
+                               reg = <0x7c0000 0x30000>;
+                               read-only;
+                       };
+
+                       ART: partition@7f0000 {
+                               label = "ART";
+                               reg = <0x7f0000 0x10000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&eth0 {
+       status = "okay";
+       phy-handle = <&swphy4>;
+       mtd-mac-address = <&info 0x8>;
+};
+
+&eth1 {
+       compatible = "syscon", "simple-mfd";
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&ART 0x1000>;
+       mtd-mac-address = <&info 0x8>;
+};
index 19a156be792999030150408878c804a27d459e3d..92d811f10b87c94d9c7265e5dcfaceb59a1d18f4 100644 (file)
@@ -109,6 +109,19 @@ define Device/tplink_archer-c7-v5
 endef
 TARGET_DEVICES += tplink_archer-c7-v5
 
 endef
 TARGET_DEVICES += tplink_archer-c7-v5
 
+define Device/tplink_cpe210-v3
+  $(Device/tplink-safeloader)
+  ATH_SOC := qca9533
+  IMAGE_SIZE := 7680k
+  DEVICE_TITLE := TP-Link CPE210 v3
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := CPE210V3
+  LOADER_TYPE := elf
+  KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+  SUPPORTED_DEVICES += cpe210-v3
+endef
+TARGET_DEVICES += tplink_cpe210-v3
+
 define Device/tplink_re350k-v1
   $(Device/tplink)
   ATH_SOC := qca9558
 define Device/tplink_re350k-v1
   $(Device/tplink)
   ATH_SOC := qca9558
index 50bbd7edc1af9de80370d6422ce927f3422505ec..f6e70e29db4c2006c9c4e5a23044a3913b2403ff 100644 (file)
@@ -196,6 +196,41 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "support-list",
        },
 
                .last_sysupgrade_partition = "support-list",
        },
 
+       /** Firmware layout for the CPE210 V3 */
+       {
+               .id     = "CPE210V3",
+               .vendor = "CPE210(TP-LINK|UN|N300-2|00000000):3.0\r\n",
+               .support_list =
+                       "SupportList:\r\n"
+                       "CPE210(TP-LINK|EU|N300-2|45550000):3.0\r\n"
+                       "CPE210(TP-LINK|UN|N300-2|00000000):3.0\r\n"
+                       "CPE210(TP-LINK|UN|N300-2):3.0\r\n"
+                       "CPE210(TP-LINK|EU|N300-2):3.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x01000},
+                       {"default-mac", 0x30000, 0x00020},
+                       {"product-info", 0x31100, 0x00100},
+                       {"device-info", 0x31400, 0x00400},
+                       {"signature", 0x32000, 0x00400},
+                       {"device-id", 0x33000, 0x00100},
+                       {"firmware", 0x40000, 0x770000},
+                       {"soft-version", 0x7b0000, 0x00100},
+                       {"support-list", 0x7b1000, 0x01000},
+                       {"user-config", 0x7c0000, 0x10000},
+                       {"default-config", 0x7d0000, 0x10000},
+                       {"log", 0x7e0000, 0x10000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "support-list",
+       },
+
        /** Firmware layout for the CPE510/520 */
        {
                .id     = "CPE510",
        /** Firmware layout for the CPE510/520 */
        {
                .id     = "CPE510",