image: ext4: allow creation of a journaling filesystem
authorJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:07 +0000 (12:44 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Jun 2014 12:44:07 +0000 (12:44 +0000)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 40925

config/Config-images.in
include/image.mk

index 368f14768d8cf3fb4540a537f37fd6b4131a7bf8..636a868d593c3446fbd4804f8e51e5373e3486fa 100644 (file)
@@ -110,6 +110,13 @@ menu "Target Images"
                        default 1024 if TARGET_EXT4_BLOCKSIZE_1K
                        depends TARGET_ROOTFS_EXT4FS
 
+               config TARGET_EXT4_JOURNAL
+                       bool "Create a journaling filesystem"
+                       depends on TARGET_ROOTFS_EXT4FS
+                       default n
+                       help
+                         Create an ext4 filesystem with a journal
+
        config TARGET_ROOTFS_ISO
                bool "iso"
                default n
index e9cb0cc8f02729fbd689ddcc72da77cbce4ba243..2f60ce06d96b08a4fe48777ae8c5dea229df0ab3 100644 (file)
@@ -190,7 +190,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_EXT4FS),)
 # generate an ext2 fs
        $(STAGING_DIR_HOST)/bin/genext2fs -U -B $(CONFIG_TARGET_EXT4_BLOCKSIZE) -b $(E2SIZE) -N $(CONFIG_TARGET_ROOTFS_MAXINODE) -d $(TARGET_DIR)/ $(KDIR)/root.ext4 -m $(CONFIG_TARGET_ROOTFS_RESERVED_PCT) $(MKFS_DEVTABLE_OPT)
 # convert it to ext4
-       $(STAGING_DIR_HOST)/bin/tune2fs -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
+       $(STAGING_DIR_HOST)/bin/tune2fs $(if $(CONFIG_TARGET_EXT4_JOURNAL),-j) -O extents,uninit_bg,dir_index $(KDIR)/root.ext4
 # fix it up
        $(STAGING_DIR_HOST)/bin/e2fsck -fy $(KDIR)/root.ext4
        $(call Image/Build,ext4)