Updated Dnsmasq to 2.43
authorSteven Barth <cyrus@openwrt.org>
Fri, 18 Jul 2008 15:32:42 +0000 (15:32 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 18 Jul 2008 15:32:42 +0000 (15:32 +0000)
SVN-Revision: 11862

package/dnsmasq/Makefile
package/dnsmasq/patches/101-ipv6.patch
package/dnsmasq/patches/200-backports.patch [deleted file]

index dab9adad7df19650bf0329ee368259df4e1c51e4..a14970a9db084598bb7a42aae3501e0b0f465049 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
-PKG_VERSION:=2.42
+PKG_VERSION:=2.43
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=78a23a31a35b8427a8589b76c1ae3ff6
+PKG_MD5SUM:=3222690c6f1f919bcefcf01a632508af
 
 include $(INCLUDE_DIR)/package.mk
 
index e11c98008742de1188acc969a06a45656f022ec3..2f973461adbf8e4e7a0301ea668aee9407f9f1f6 100644 (file)
@@ -1,7 +1,8 @@
-diff -ur dnsmasq-2.42.orig/src/config.h dnsmasq-2.42/src/config.h
---- dnsmasq-2.42.orig/src/config.h     2008-06-03 16:38:25.000000000 +0200
-+++ dnsmasq-2.42/src/config.h  2008-06-03 16:38:43.000000000 +0200
-@@ -322,8 +322,9 @@
+Index: dnsmasq-2.43/src/config.h
+===================================================================
+--- dnsmasq-2.43.orig/src/config.h     2008-07-18 16:36:53.000000000 +0200
++++ dnsmasq-2.43/src/config.h  2008-07-18 16:37:40.000000000 +0200
+@@ -288,8 +288,9 @@
  /* We assume that systems which don't have IPv6
     headers don't have ntop and pton either */
  
diff --git a/package/dnsmasq/patches/200-backports.patch b/package/dnsmasq/patches/200-backports.patch
deleted file mode 100644 (file)
index 19c52d9..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: dnsmasq-2.42/src/dnsmasq.c
-===================================================================
---- dnsmasq-2.42.orig/src/dnsmasq.c    2008-06-28 23:37:18.000000000 +0200
-+++ dnsmasq-2.42/src/dnsmasq.c 2008-06-28 23:37:20.000000000 +0200
-@@ -297,8 +297,11 @@
-         capget(hdr, NULL);
-         if (hdr->version != LINUX_CAPABILITY_VERSION_1)
-           {
--            /* if not version 1, use version 2 */
--            hdr->version = LINUX_CAPABILITY_VERSION_2;
-+            /* if unknown version, use largest supported version (3) 
-+                 * backported fix from 2.43 to suppress kernel warning
-+                 */
-+                if (hdr->version != LINUX_CAPABILITY_VERSION_2)
-+                      hdr->version = LINUX_CAPABILITY_VERSION_3;
-             capsize = 2;
-           }
-         hdr->pid = 0; /* this process */
-Index: dnsmasq-2.42/src/dnsmasq.h
-===================================================================
---- dnsmasq-2.42.orig/src/dnsmasq.h    2008-06-28 23:37:48.000000000 +0200
-+++ dnsmasq-2.42/src/dnsmasq.h 2008-06-28 23:37:55.000000000 +0200
-@@ -100,6 +100,7 @@
- extern int capget(cap_user_header_t header, cap_user_data_t data);
- #define LINUX_CAPABILITY_VERSION_1  0x19980330
- #define LINUX_CAPABILITY_VERSION_2  0x20071026
-+#define LINUX_CAPABILITY_VERSION_3  0x20080522
- #include <sys/prctl.h>
- #elif defined(HAVE_SOLARIS_PRIVS)