kernel: bump 4.9 to 4.9.124
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 24 Aug 2018 15:58:52 +0000 (17:58 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 28 Aug 2018 21:06:47 +0000 (23:06 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
12 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/910-unaligned_access_hacks.patch
target/linux/generic/backport-4.9/024-8-tcp-tsq-move-tsq_flags-close-to-sk_wmem_alloc.patch
target/linux/generic/backport-4.9/090-net-generalize-napi_complete_done.patch
target/linux/generic/pending-4.9/630-packet_socket_type.patch
target/linux/lantiq/patches-4.9/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/layerscape/patches-4.9/702-pci-support-layerscape.patch
target/linux/layerscape/patches-4.9/808-guts-support-layerscape.patch
target/linux/layerscape/patches-4.9/817-usb-support-layerscape.patch
target/linux/sunxi/patches-4.9/0050-stmmac-form-4-10.patch
target/linux/sunxi/patches-4.9/0051-stmmac-form-4-11.patch
target/linux/sunxi/patches-4.9/0053-stmmac-form-4-13.patch

index 89ba1bb0505ceaade45ba6a5786ab52b46c6518c..9c9490fef64273fc7621fd50e5b5121d13ed0185 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .123
 LINUX_VERSION-4.14 = .66
+LINUX_VERSION-4.9 = .124
 
-LINUX_KERNEL_HASH-4.9.123 = 8d12ceab9f8cbfd0555c881b35ed4384cf3ea8e223d894c030b04786005e5071
 LINUX_KERNEL_HASH-4.14.66 = a38061ca4c864d11a72beb3dc5918a99f13372fe9ee35508d004fdfabd460413
+LINUX_KERNEL_HASH-4.9.124 = 5ca6b0d48c8dd1265005169f1b97149a4e893668c0d8aa566a73c7663c8e4311
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 620020370623cdc193400ec1a7bcabc5888cc709..5c2a435c9f45debf4025d0e080e6f08fcf686560 100644 (file)
  
  #define       IP6_MF          0x0001
  #define       IP6_OFFSET      0xFFF8
-@@ -450,8 +450,8 @@ static inline void __ipv6_addr_set_half(
+@@ -443,8 +443,8 @@ static inline void __ipv6_addr_set_half(
        }
  #endif
  #endif
  }
  
  static inline void ipv6_addr_set(struct in6_addr *addr, 
-@@ -510,6 +510,8 @@ static inline bool ipv6_prefix_equal(con
+@@ -503,6 +503,8 @@ static inline bool ipv6_prefix_equal(con
        const __be32 *a1 = addr1->s6_addr32;
        const __be32 *a2 = addr2->s6_addr32;
        unsigned int pdw, pbi;
  
        /* check complete u32 in prefix */
        pdw = prefixlen >> 5;
-@@ -518,7 +520,9 @@ static inline bool ipv6_prefix_equal(con
+@@ -511,7 +513,9 @@ static inline bool ipv6_prefix_equal(con
  
        /* check incomplete u32 in prefix */
        pbi = prefixlen & 0x1f;
                return false;
  
        return true;
-@@ -662,13 +666,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -655,13 +659,13 @@ static inline void ipv6_addr_set_v4mappe
   */
  static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
  {
                if (xb)
                        return i * 32 + 31 - __fls(ntohl(xb));
        }
-@@ -837,17 +841,18 @@ static inline int ip6_default_np_autolab
+@@ -830,17 +834,18 @@ static inline int ip6_default_np_autolab
  static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
                                __be32 flowlabel)
  {
index 0a5b9ead9dc4bb63825fdcbddba36806a848292c..4a3f355b4d8ef2c9b069a6ec37eff7fd59caa8a3 100644 (file)
@@ -134,7 +134,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                if (tcp_small_queue_check(sk, skb, 0))
                        break;
  
-@@ -3546,8 +3546,6 @@ void __tcp_send_ack(struct sock *sk, u32
+@@ -3542,8 +3542,6 @@ void __tcp_send_ack(struct sock *sk, u32
        /* We do not want pure acks influencing TCP Small Queues or fq/pacing
         * too much.
         * SKB_TRUESIZE(max(1 .. 66, MAX_TCP_HEADER)) is unfortunately ~784
index 4a5a89013c91a1233d6731738d34cc1543fd40b4..127707827e21c9a7fd5d5761a1c7b8a32d2f071e 100644 (file)
@@ -388,7 +388,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
                                        BNX2_PCICFG_INT_ACK_CMD_INDEX_VALID |
 --- a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.c
 +++ b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_cmn.c
-@@ -3230,7 +3230,7 @@ static int bnx2x_poll(struct napi_struct
+@@ -3236,7 +3236,7 @@ static int bnx2x_poll(struct napi_struct
                 * has been updated when NAPI was scheduled.
                 */
                if (IS_FCOE_FP(fp)) {
index 08d730ac31ed16381e05a176884b071bee7afd0d..0bf9339d1122bb96c73b5adaaecbc49f967d70f5 100644 (file)
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -3260,6 +3262,7 @@ static int packet_create(struct net *net
+@@ -3262,6 +3264,7 @@ static int packet_create(struct net *net
        mutex_init(&po->pg_vec_lock);
        po->rollover = NULL;
        po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3873,6 +3876,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3875,6 +3878,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3925,6 +3938,13 @@ static int packet_getsockopt(struct sock
+@@ -3927,6 +3940,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index 91a6acce3a9374a813b2da1c51a3b6985900c7db..f4013f5e21568a01e6c053674a36196752fe3ed8 100644 (file)
@@ -5494,7 +5494,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1250,6 +1250,8 @@ void pci_walk_bus(struct pci_bus *top, i
+@@ -1252,6 +1252,8 @@ void pci_walk_bus(struct pci_bus *top, i
                  void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
index 724c6841f8deed0b61ec8754e173a1eeed520a01..03c3fb7cb98430df44c64f15b1e4ca1a733629c0 100644 (file)
@@ -2074,7 +2074,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 +DECLARE_PCI_FIXUP_FINAL(PCI_VENDOR_ID_FREESCALE, PCI_ANY_ID, quirk_fsl_no_msi);
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1823,6 +1823,7 @@ void pcibios_release_device(struct pci_d
+@@ -1825,6 +1825,7 @@ void pcibios_release_device(struct pci_d
  void pcibios_penalize_isa_irq(int irq, int active);
  int pcibios_alloc_irq(struct pci_dev *dev);
  void pcibios_free_irq(struct pci_dev *dev);
index 0999832a1621ae63a8e202ba033020bdaacc376a..26412c5ebef492d702ee89e497125f2f7e4b8b4a 100644 (file)
@@ -258,7 +258,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 +module_exit(fsl_guts_exit);
 --- a/include/linux/fsl/guts.h
 +++ b/include/linux/fsl/guts.h
-@@ -29,83 +29,112 @@
+@@ -30,83 +30,112 @@
   * #ifdefs.
   */
  struct ccsr_guts {
index 5af0b088a86f220387be886c02259c4a4fcb4a3b..7afef36e4be8b07760a56c2932acee615200441e 100644 (file)
@@ -1494,7 +1494,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                while (ep_ring->dequeue != td->last_trb)
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1604,14 +1604,38 @@ int xhci_urb_dequeue(struct usb_hcd *hcd
+@@ -1609,14 +1609,38 @@ int xhci_urb_dequeue(struct usb_hcd *hcd
                        ret = -ENOMEM;
                        goto done;
                }
index 7549d4995a08d5f7c7f5d2f4a13078fc14a00218..22d62f0960780be9d805449703a26f8aef362c8b 100644 (file)
  };
 --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-socfpga.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-socfpga.c
-@@ -380,8 +380,8 @@ static int socfpga_dwmac_resume(struct d
+@@ -390,8 +390,8 @@ static int socfpga_dwmac_resume(struct d
         * control register 0, and can be modified by the phy driver
         * framework.
         */
index cd3e52a21250698dd0d41100009858bc1984f818..2ce23e2eb5fe445cf63e140f5f3b680dec7a9106 100644 (file)
        { .compatible = "rockchip,rk3399-gmac", .data = &rk3399_ops },
 --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-socfpga.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-socfpga.c
-@@ -341,7 +341,7 @@ static int socfpga_dwmac_probe(struct pl
+@@ -351,7 +351,7 @@ static int socfpga_dwmac_probe(struct pl
         * mode. Create a copy of the core reset handle so it can be used by
         * the driver later.
         */
index d71821ad7c00b12592a4cbe8f8946859bc960c53..abdc618e6bf73fa81e6782a5345b4381f5539462 100644 (file)
@@ -47,7 +47,7 @@
  struct mii_regs {
 --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-socfpga.c
 +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-socfpga.c
-@@ -269,7 +269,10 @@ static int socfpga_dwmac_set_phy_mode(st
+@@ -270,7 +270,10 @@ static int socfpga_dwmac_set_phy_mode(st
        ctrl &= ~(SYSMGR_EMACGRP_CTRL_PHYSEL_MASK << reg_shift);
        ctrl |= val << reg_shift;