ppp: - implement coldplugging for pppoa interfaces - honour device option to select...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 19 Oct 2010 06:42:37 +0000 (06:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 19 Oct 2010 06:42:37 +0000 (06:42 +0000)
SVN-Revision: 23530

package/ppp/Makefile
package/ppp/files/pppoa.sh

index 1e46cdda32b4cac20afb070c3947dc30fd5f2d3f..b893b1ec5239753beab9bca9220e9ca794e3552e 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index adbcdf9fbbbcbb9a4d9b1e4982d508bb9d34cf8b..59e35c2dca558263250082c6628be3337fadb137 100644 (file)
@@ -1,9 +1,12 @@
+coldplug_interface_pppoa() {
+       setup_interface_pppoa x "$1"
+}
+
 stop_interface_pppoa() {
        stop_interface_ppp "$1"
 }
 
 setup_interface_pppoa() {
-       local iface="$1"
        local config="$2"
 
        local device
@@ -29,9 +32,8 @@ setup_interface_pppoa() {
 
        local mtu
        config_get mtu "$config" mtu
-       mtu=${mtu:-1500}
 
        start_pppd "$config" \
-               plugin pppoatm.so ${vpi:-8}.${vci:-35} ${encaps} \
-               mtu $mtu mru $mtu
+               plugin pppoatm.so ${device:+$device.}${vpi:-8}.${vci:-35} \
+               ${encaps} ${mtu:+mtu $mtu mru $mtu}
 }