kernel: bump 4.9 to 4.9.154
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 31 Jan 2019 14:56:42 +0000 (15:56 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 1 Feb 2019 10:41:00 +0000 (11:41 +0100)
Refreshed all patches.

Adapted patches:
- 012-kbuild-add-macro-for-controlling-warnings-to-linux-c.patch

Compile-tested on: ar7
Runtime-tested on: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/backport-4.9/012-kbuild-add-macro-for-controlling-warnings-to-linux-c.patch
target/linux/generic/backport-4.9/021-bridge-multicast-to-unicast.patch
target/linux/generic/hack-4.9/641-bridge_port_isolate.patch
target/linux/generic/hack-4.9/661-use_fq_codel_by_default.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch
target/linux/generic/pending-4.9/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/ixp4xx/patches-4.9/160-delayed_uart_io.patch

index bd16b73826bc1780468a34f0134b8ce9bfb247f0..e52b791d8b2ad1a05e192aa4696fa6b9a529bec8 100644 (file)
@@ -3,12 +3,12 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .133
-LINUX_VERSION-4.9 = .153
+LINUX_VERSION-4.9 = .154
 LINUX_VERSION-4.14 = .96
 LINUX_VERSION-4.19 = .18
 
 LINUX_KERNEL_HASH-3.18.133 = 3ec7f47365a8a050e629a5016e90e38a800e840c844901c979e9e796f8dc6711
-LINUX_KERNEL_HASH-4.9.153 = 9066929ec2550794ae107350a5f3c5b648438aa915cfc62bac5b7a54b9d7731a
+LINUX_KERNEL_HASH-4.9.154 = 5b314f1ac16f78e10acea0053f0c758e696b28f80272064e0a06bc69dc9d5696
 LINUX_KERNEL_HASH-4.14.96 = 110daeae1a416b7e0ec8dce5e86d67552deeb4567f696c3869389be239f0ecb5
 LINUX_KERNEL_HASH-4.19.18 = 5ffdc068f9bf768b7cd5a8a2271d1370c2326e967848b13e21dfdbb1ef0ff3f1
 
index ccc7232751f59576b1d6fe685187a2811561845f..4b22ca0e3f69e9250a667454191ba4884087a142 100644 (file)
@@ -84,10 +84,11 @@ Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
 
 --- a/include/linux/compiler-gcc.h
 +++ b/include/linux/compiler-gcc.h
-@@ -334,3 +334,28 @@
-  * code
-  */
- #define uninitialized_var(x) x = x
+@@ -338,3 +338,30 @@
+ #if GCC_VERSION >= 50100
+ #define COMPILER_HAS_GENERIC_BUILTIN_OVERFLOW 1
+ #endif
++
 +
 +/*
 + * Turn individual warnings and errors on and off locally, depending
@@ -113,6 +114,7 @@ Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
 +#else
 +#define __diag_GCC_8(s)
 +#endif
++
 --- a/include/linux/compiler.h
 +++ b/include/linux/compiler.h
 @@ -578,4 +578,23 @@ static __always_inline void __write_once
index 7c36a767c7467fcf0af0ae7bf41c340380ea7371..4b7e8ba75a69c1aa82382b3e1a357f60ec71d02b 100644 (file)
@@ -51,7 +51,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  #define IFLA_BRPORT_MAX (__IFLA_BRPORT_MAX - 1)
 --- a/net/bridge/br_forward.c
 +++ b/net/bridge/br_forward.c
-@@ -174,6 +174,29 @@ out:
+@@ -173,6 +173,29 @@ out:
        return p;
  }
  
@@ -81,7 +81,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
  /* called under rcu_read_lock */
  void br_flood(struct net_bridge *br, struct sk_buff *skb,
              enum br_pkt_type pkt_type, bool local_rcv, bool local_orig)
-@@ -242,10 +265,20 @@ void br_multicast_flood(struct net_bridg
+@@ -241,10 +264,20 @@ void br_multicast_flood(struct net_bridg
                rport = rp ? hlist_entry(rp, struct net_bridge_port, rlist) :
                             NULL;
  
index c545fa17ef8b47ae43e83a59329364db1f7fd1b0..a436dd2b1e0a85979bad5578c0958b6d52332b07 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/bridge/br_forward.c
 +++ b/net/bridge/br_forward.c
-@@ -141,6 +141,9 @@ static int deliver_clone(const struct ne
+@@ -140,6 +140,9 @@ static int deliver_clone(const struct ne
  void br_forward(const struct net_bridge_port *to,
                struct sk_buff *skb, bool local_rcv, bool local_orig)
  {
@@ -35,7 +35,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (to && should_deliver(to, skb)) {
                if (local_rcv)
                        deliver_clone(to, skb, local_orig);
-@@ -206,6 +209,8 @@ void br_flood(struct net_bridge *br, str
+@@ -205,6 +208,8 @@ void br_flood(struct net_bridge *br, str
        struct net_bridge_port *p;
  
        list_for_each_entry_rcu(p, &br->port_list, list) {
index 981170cbb1e2b868d9a0c1626fd12c6f4a9aec68..34fc2a37c3f19c0f982a1c9a3ae0c047a3ce60da 100644 (file)
@@ -44,7 +44,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
          device, it has to decide which ones to send first, which ones to
 --- a/net/sched/sch_api.c
 +++ b/net/sched/sch_api.c
-@@ -1978,7 +1978,7 @@ static int __init pktsched_init(void)
+@@ -1977,7 +1977,7 @@ static int __init pktsched_init(void)
                return err;
        }
  
index 5632d6ebda6af8e57e985469f7d48c790580fd13..91d1d283511b78e4db4be79eb839ad39d285a173 100644 (file)
@@ -339,7 +339,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2667,10 +2667,12 @@ static const struct file_operations fib_
+@@ -2677,10 +2677,12 @@ static const struct file_operations fib_
  
  int __net_init fib_proc_init(struct net *net)
  {
@@ -354,7 +354,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2680,17 +2682,21 @@ int __net_init fib_proc_init(struct net
+@@ -2690,17 +2692,21 @@ int __net_init fib_proc_init(struct net
        return 0;
  
  out3:
index fa8c3b75ded31818979882211e4ce5c91add2d3e..3f6b406cf27e1f220113de769fba12c195bd9dae 100644 (file)
@@ -66,7 +66,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static void rt_fibinfo_free(struct rtable __rcu **rtp)
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2396,6 +2396,7 @@ static const char *const rtn_type_names[
+@@ -2406,6 +2406,7 @@ static const char *const rtn_type_names[
        [RTN_THROW] = "THROW",
        [RTN_NAT] = "NAT",
        [RTN_XRESOLVE] = "XRESOLVE",
index 12df228516b0011439ea5458ac4d1053c6726030..4e13ec950c251d72dfa233bf3120f181eebefee0 100644 (file)
@@ -18,7 +18,7 @@
                uart->capabilities      = up->capabilities;
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -2250,6 +2250,7 @@ uart_report_port(struct uart_driver *drv
+@@ -2254,6 +2254,7 @@ uart_report_port(struct uart_driver *drv
                snprintf(address, sizeof(address),
                         "I/O 0x%lx offset 0x%x", port->iobase, port->hub6);
                break;
@@ -26,7 +26,7 @@
        case UPIO_MEM:
        case UPIO_MEM16:
        case UPIO_MEM32:
-@@ -2914,6 +2915,7 @@ int uart_match_port(struct uart_port *po
+@@ -2918,6 +2919,7 @@ int uart_match_port(struct uart_port *po
        case UPIO_HUB6:
                return (port1->iobase == port2->iobase) &&
                       (port1->hub6   == port2->hub6);