linux/generic: refresh 2.6.37 patches
authorAlexandros C. Couloumbis <alex@ozo.com>
Tue, 23 Nov 2010 14:04:42 +0000 (14:04 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Tue, 23 Nov 2010 14:04:42 +0000 (14:04 +0000)
SVN-Revision: 24111

12 files changed:
target/linux/generic/patches-2.6.37/100-netfilter_layer7_2.22.patch
target/linux/generic/patches-2.6.37/103-netfilter_layer7_2.6.36_fix.patch
target/linux/generic/patches-2.6.37/180-netfilter_depends.patch
target/linux/generic/patches-2.6.37/240-packet_socket_type.patch
target/linux/generic/patches-2.6.37/400-ledtrig_morse.patch
target/linux/generic/patches-2.6.37/402-ledtrig_netdev.patch
target/linux/generic/patches-2.6.37/420-gpiodev.patch
target/linux/generic/patches-2.6.37/801-usb_serial_endpoint_size.patch
target/linux/generic/patches-2.6.37/840-unable_to_open_console.patch
target/linux/generic/patches-2.6.37/922-gpiommc.patch
target/linux/generic/patches-2.6.37/980-vm_exports.patch
target/linux/generic/patches-2.6.37/999-use_preinit_as_init.patch

index 4d969e290b025d80d48ac17fa747cf58de410084..88b656b5e4d7a89291d56e6c9f77c8d6c66c4f17 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -946,6 +946,27 @@ config NETFILTER_XT_MATCH_STATE
+@@ -948,6 +948,27 @@ config NETFILTER_XT_MATCH_STATE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
 +}
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -202,6 +202,14 @@ destroy_conntrack(struct nf_conntrack *n
+@@ -212,6 +212,14 @@ destroy_conntrack(struct nf_conntrack *n
         * too. */
        nf_ct_remove_expectations(ct);
  
                BUG_ON(hlist_nulls_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnnode));
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -178,6 +178,12 @@ static int ct_seq_show(struct seq_file *
+@@ -200,6 +200,12 @@ static int ct_seq_show(struct seq_file *
                goto release;
  #endif
  
index e9aa3c967fa4f74358094b07fc39e11c4f7428bb..1082da5b679508924988c753c301fb2efcdaf01f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -781,6 +781,27 @@ config NETFILTER_XT_MATCH_IPVS
+@@ -762,6 +762,27 @@ config NETFILTER_XT_MATCH_IPVS
  
          If unsure, say N.
  
@@ -28,7 +28,7 @@
  config NETFILTER_XT_MATCH_LENGTH
        tristate '"length" match support'
        depends on NETFILTER_ADVANCED
-@@ -966,26 +987,11 @@ config NETFILTER_XT_MATCH_STATE
+@@ -948,26 +969,11 @@ config NETFILTER_XT_MATCH_STATE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
index d270e9020bf575526eb0104b9d19d57407c75e22..22bf51c3a9006bad65c663942182d7a7830985db 100644 (file)
@@ -8,7 +8,7 @@
        depends on NETFILTER_ADVANCED
        help
          H.323 is a VoIP signalling protocol from ITU-T. As one of the most
-@@ -558,7 +557,6 @@ config NETFILTER_XT_TARGET_SECMARK
+@@ -570,7 +569,6 @@ config NETFILTER_XT_TARGET_SECMARK
  
  config NETFILTER_XT_TARGET_TCPMSS
        tristate '"TCPMSS" target support'
index 204512ff11e800f2e1c6e6421bf24492a8252865..f5cb465e939ca4d5b9a0c170394dfed898cd2ed9 100644 (file)
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -2054,6 +2058,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -2057,6 +2061,16 @@ packet_setsockopt(struct socket *sock, i
                po->tp_tstamp = val;
                return 0;
        }
@@ -116,7 +116,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        default:
                return -ENOPROTOOPT;
        }
-@@ -2111,6 +2125,13 @@ static int packet_getsockopt(struct sock
+@@ -2114,6 +2128,13 @@ static int packet_getsockopt(struct sock
  
                data = &val;
                break;
index 60a9f3890305cc334fdb9b49f15da337acb23bca..3252cd5b85fe95df32c899aeb5934ac6b3deadac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -389,4 +389,8 @@ endif # LEDS_TRIGGERS
+@@ -407,4 +407,8 @@ endif # LEDS_TRIGGERS
  
  endif # LEDS_CLASS
  
@@ -11,7 +11,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -50,3 +50,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
+@@ -52,3 +52,4 @@ obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) +=
  obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT)  += ledtrig-backlight.o
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index 8c6fb17d8fc94f9390c99a66782f01c643664fc7..7f559e19e5f94138945342e97a9328d6cec3d20d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/leds/Kconfig
 +++ b/drivers/leds/Kconfig
-@@ -393,4 +393,11 @@ config LEDS_TRIGGER_MORSE
+@@ -411,4 +411,11 @@ config LEDS_TRIGGER_MORSE
        tristate "LED Morse Trigger"
        depends on LEDS_TRIGGERS
  
@@ -14,7 +14,7 @@
  endif # NEW_LEDS
 --- a/drivers/leds/Makefile
 +++ b/drivers/leds/Makefile
-@@ -51,3 +51,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
+@@ -53,3 +53,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
  obj-$(CONFIG_LEDS_TRIGGER_GPIO)               += ledtrig-gpio.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
  obj-$(CONFIG_LEDS_TRIGGER_MORSE)      += ledtrig-morse.o
index 0915799bc79f0e078b448bef7e7986a165794a5f..690b5e6cd8211ad6d4b7b35b3ff4ab4957590b26 100644 (file)
@@ -17,7 +17,7 @@
        depends on BLOCK
 --- a/drivers/char/Makefile
 +++ b/drivers/char/Makefile
-@@ -99,6 +99,7 @@ obj-$(CONFIG_SCx200_GPIO)    += scx200_gpio
+@@ -82,6 +82,7 @@ obj-$(CONFIG_SCx200_GPIO)    += scx200_gpio
  obj-$(CONFIG_PC8736x_GPIO)    += pc8736x_gpio.o
  obj-$(CONFIG_NSC_GPIO)                += nsc_gpio.o
  obj-$(CONFIG_CS5535_GPIO)     += cs5535_gpio.o
index 79c587c1ef369343c469aef4b0a4fe8d1bcc8e38..aa64c686f33beb80d80a8790e6b6cf3c95114af0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/serial/usb-serial.c
 +++ b/drivers/usb/serial/usb-serial.c
-@@ -61,6 +61,7 @@ static struct usb_driver usb_serial_driv
+@@ -60,6 +60,7 @@ static struct usb_driver usb_serial_driv
     drivers depend on it.
  */
  
@@ -8,7 +8,7 @@
  static int debug;
  /* initially all NULL */
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];
-@@ -913,7 +914,7 @@ int usb_serial_probe(struct usb_interfac
+@@ -912,7 +913,7 @@ int usb_serial_probe(struct usb_interfac
                }
                buffer_size = serial->type->bulk_in_size;
                if (!buffer_size)
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc(buffer_size, GFP_KERNEL);
-@@ -1386,3 +1387,5 @@ MODULE_LICENSE("GPL");
+@@ -1385,3 +1386,5 @@ MODULE_LICENSE("GPL");
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index bfb4e0d165f1909a09668b885b9530f090adc336..8f1a4cb8ed1bb7f5c4cef8205434e4779ad1e315 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -891,7 +891,7 @@ static int __init kernel_init(void * unu
+@@ -890,7 +890,7 @@ static int __init kernel_init(void * unu
  
        /* Open the /dev/console on the rootfs, this should never fail */
        if (sys_open((const char __user *) "/dev/console", O_RDWR, 0) < 0)
index 5cdb1318bb202aa6b1b451ea00344979cde80f39..8eb66e4563363ac99411511ee2277830d9a01ca5 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -2696,6 +2696,11 @@ T:      git git://git.kernel.org/pub/scm/linu
+@@ -2706,6 +2706,11 @@ T:      git git://git.kernel.org/pub/scm/linu
  S:    Maintained
  F:    drivers/media/video/gspca/
  
index 09ccb397f2a85a7a0d37477dcdc959020b439a81..5f0c3d48363bbea4b87b8f06b594f04358487b8d 100644 (file)
@@ -48,7 +48,7 @@
  {
 --- a/kernel/exit.c
 +++ b/kernel/exit.c
-@@ -505,6 +505,7 @@ struct files_struct *get_files_struct(st
+@@ -513,6 +513,7 @@ struct files_struct *get_files_struct(st
  
        return files;
  }
@@ -56,7 +56,7 @@
  
  void put_files_struct(struct files_struct *files)
  {
-@@ -526,6 +527,7 @@ void put_files_struct(struct files_struc
+@@ -534,6 +535,7 @@ void put_files_struct(struct files_struc
                rcu_read_unlock();
        }
  }
@@ -76,7 +76,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -4573,6 +4573,7 @@ int can_nice(const struct task_struct *p
+@@ -4588,6 +4588,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= task_rlimit(p, RLIMIT_NICE) ||
                capable(CAP_SYS_NICE));
  }
index 650c677debd2773b6a9a19e34e890208b4910d86..e0a76229c142c8f0b426c89bbc01e3a1a8093566 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -845,10 +845,7 @@ static noinline int init_post(void)
+@@ -844,10 +844,7 @@ static noinline int init_post(void)
                printk(KERN_WARNING "Failed to execute %s.  Attempting "
                                        "defaults...\n", execute_command);
        }